Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

GHG emissions

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Jose Agustin

New member
I am running WRF-chem for GHG using emiss_opt=16, chem_opt=16. The WRF4.0 was running for radm2 mechanism (emiss_opt=3, chem_opt=106) and in order to run the following options also were changed: gas_drydep_opt=0 and vprm_opt = “VPRM_table_TROPICS".
In the results there is no increase in ambient concentrations due to anthropogenic emissions.
I think that the wrf does not read emissions because a missing emissions file or the variables name has to be changed.
if is it the case which name has to have the file and the variables?

View attachment namelist.input
hi Jose,

I've not used the GHG version of WRF-Chem, so my advice here will be generic - hopefully it will help you to start working out your problem though.

It is helpful to check the "Registry/registry.chem" source code file for WRF-Chem, to see what variables different options use.

For example, the code for your two different emission options is:
package   eradmsorg       emiss_opt==3                   -             emis_ant:e_iso,e_so2,e_no,e_no2,e_co,e_eth,e_hc3,e_hc5,e_hc8,e_xyl,e_ol2,e_olt,e_oli,e_tol,e_csl,e_hcho,e_ald,e_ket,e_ora2,e_nh3,e_pm25i,e_pm25j,e_pm_10,e_eci,e_ecj,e_orgi,e_orgj,e_so4i,e_so4j,e_no3i,e_no3j,e_naaj,e_naai,e_orgi_a,e_orgj_a,e_orgi_bb,e_orgj_bb
package   eco2            emiss_opt==16                  -             emis_ant:e_co2,e_co2tst,e_co

The only shared emission variable between these two is "e_co" - so if your emission files have been created for the radm2 mechanism, then that is the only variable that will be read in. Check the wrfchemi* files you have (using ncdump or ncview) to see what variables are in your emission files. If they are not then you will have to create new emission files with the correct variables.

If you want to check that WRF is reading in the emission variables you give it then you can make WRF output them too.

In your namelist you have specified a text file to read in changes to what I/O variables you will use:
 iofields_filename                   ="ignore_vars_d1.txt","ignore_vars_d2.txt"

You could add this line of code to your "ignore_vars_d1.txt" file:

This will add these variables (if they exist) to your domain 1 wrfout files - you can then check these to make sure that WRF is reading in the correct emissions. If it is, but your chemical fields are still not changing as you expect, then you will probably have to start digging into the code to see what is causing the problem.