Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Invalid memory reference while running regional atmosphere core

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
While I run atmosphere core with regional 15 km mesh, no matter using 1 core or 32 core, I get error file attached and don't get log.atmosphere.0000.err. The gnu version is 5.4.0.


  • log.err.txt
    1,013 bytes · Views: 55
  • log_32.err.txt
    10.8 KB · Views: 55
  • namelist.atmosphere.txt
    1.7 KB · Views: 55
  • streams.atmosphere.txt
    1.5 KB · Views: 52
Are you able to successfully produce a global simulation using the same init_atmosphere_model and atmosphere_model executables? Can you attach the log.atmosphere.0000.out file to give a better indication of where in the model execution the simulation is crashing?
After using 120 km global mesh to check MPAS-Model, I successfully produce a '' file and a '' file. So it looks like init_atmosphere core works. While running atmosphere core, I get the same error.

ps: prefix=01 means the first simulation with region 15 km mesh
prefix=02 means the second simulation with global 120 km mesh


  • 01_log.atmosphere.0000.out.txt
    8.2 KB · Views: 54
  • 02_bsub_km.err.txt
    9.9 KB · Views: 50
  • 02_log.atmosphere.0000.out.txt
    8.4 KB · Views: 56
  • 02_namelist.atmosphere.txt
    1.7 KB · Views: 47
  • 02_streams.atmosphere.txt
    1.6 KB · Views: 52
Thanks very much for the additional files. It looks like the model is getting to the point of trying to read the full initial conditions fields from the '' file.

I did notice that you are reading the initial conditions for the global run from a netCDF-4-formatted file. Could you try re-running the init_atmosphere core to produce a new file in CDF-2 format (the default)? You can do this by omitting any specification of 'io_type' in your streams.init_atmosphere file, then removing the specification io_type="netcdf4" from your streams.atmosphere file.

My guess at this point is that the netCDF-4 format is the problem, and switching to the default format (CDF-2) may resolve the issue.