Key error when running real.exe and wrf.exe

This post was from a previous version of the WRF&MPAS-A Support Forum. Please do not add new replies here and if you would like the thread moved out of the Historical / Archive section then contact us, making sure to include the link of the thread to be moved.

mmah1986

New member
Hello,

I have a question about real.exe and wrf.exe; When I do "./real.exe." or "./wrf.exe" inside the directory "/home/mani/WRF-4.2.1/test/em_real" where I've got my test case setup, I get the mesage that "Invalid MIT-MAGIC-COOKIE-1 key" - however all the other steps (ungrib, geogrid, etc) work ok (without this message). The commands "./real.exe." and "./wrf.exe" work ok as well (they just show that invalid key message). When I try "xauth list" I get 2 "MIT-MAGIC-COOKIE-1"s; I have also tried "xauth remove :1" (the value of my $DISPLAY is :1) which removes these two keys, but then I get "No protocol specified" (rather than "Invalid MIT-MAGIC-COOKIE-1 key").

I would greatly appreciate it, if you could help me with this.

Cheers,
Mani
 

Ming Chen

Moderator
Staff member
Mani,
I am pretty sure this is an issue related to specific environment settings of your machine. Please talk to your computer manage and figure out what is wrong.
 

mmah1986

New member
Hi Ming,

Thanks for the reply; I am running these commands on the Ubuntu installed on my own PC. I tried to look over the internet for the solution (I did so very extensively), but could not solve my problem. The problem seems somewhat peculiar, as it does not happen with the geogrid, ungrib or metgrid, but happens with the real.exe and wrf.exe.

I am still looking for a solution.

Mani
 
Top