Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

MPAS can't find Thompson microphysics tables (solved)


I've seen a similar issue elsewhere (MPT Error running MPAS atmosphere_model) but the solution adopted there didn't work for me.

When I attempt to run the model I get the following error:

Beginning MPAS-atmosphere Error Log File for task       0 of      50
    Opened at 2022/11/01 08:58:37

ERROR: ------------------------------ FATAL CALLED ------------------------------
ERROR: --- tables to run the Thompson cloud microphysics scheme do not exist: run build_tables first.
CRITICAL ERROR: MPAS core_physics abort
Logging complete.  Closing file at 2022/11/01 08:58:37

I tried different things: first, as suggested by the error message, I ran build_tables (which successfully generated the tables) and then linked them to the directory where I'm attempting to run the model, but that didn't work (I've got the same error message). Then I just copied them to the WRF physics directory (/src/core_atmosphere/physics/physics_wrf/files/) and then recompiled the model (which was successful). However, none of that to worked and I get the same error.

As you can see on the print screen bellow, the files in the directory I'm trying to run the mode are correctly linked:

Screen Shot 2022-11-02 at 12.39.22.png

What can I be possibly be doing wrong?
I can't think of any good reason why the model might not be able to open the Thompson lookup tables, as they do appear to be correctly linked into your run directory. Out of curiosity, if you run 'ls -lL' in your run directory, do all of the symbolic links resolve, and what do the permissions and file sizes for the Thompson tables look like?

The code that checks for the presence of these tables begins around line 398 in mpas_atmphys_control.F . It may be worth uncommenting a few of the print statements just before the critical error message. Or, you could try modifying the code so that the checks always succeed if there's some reason to think that the Fortran INQUIRE statements are returning erroneous results for these files.
Hello Mr. Duda. Thank you very much for your reply.

I managed to make it work.. your comment regarding the permissions helped me to identify the problem: it seems that the system I was using was having some bug issues where the files were being created with wrong usernames. So, I created the tables but they were created under a different username and when I attempted to access them with my real username I did not have the permission to do so.
Hello, I also encountered a similar problem, but the following interface appeared when I added the SKEBS disturbance. I don't know why? Want the answer to be a missing package or a coding error?_KTL02JP9@G)JA`(FJKBX0F.png