Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Problem installing UPP 4.1

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I'm having an issue installing UPP4.1. I get the following error when running ./compile after .configure with gfortran (option 12) and don't know what to do to solve it, any help would be appreciated.

make: *** No rule to make target 'kinds_mod.o', needed by 'VRBLS2D_mod.o'. Stop.

If I try option 8, I get even more errors.

I have installed the NCEP libraries with no issues and I have set the environment to the NCEP libraries path.

Many thanks all.
What platform/compiler version are you using? Our testing used gnu v8.3.0 and intel v18.0.5. We can't guarantee that a significantly different version would work. Please also note that both the NCEPLIBS and UPP need to be built with the same library versions.
I have tried gnu 4 and 9 previously. Neither seems to work. I will try recompiling everything with gnu v8.3.0. Interestingly, it states that for NCEPLIBS "To build these libraries, users are advised to load the same modules and set the environment variables (compilers and flags) as in the respective module file of NEMSfv3gfs (NEMSFV3GFS_DIR/modulefiles/SYSTEM.COMPILER/fv3)", however this directory no longer exists, so it's not documented anywhere what modules and environment variables are needed to build this version of NCEPLIBS, which I think is the problem.
OK, I sort of solved it.

I am using WSL rather than a pure distro, and I upgraded from WSL1 to WSL2 and then reinstalled everything from scratch in the home directory in a folder called Build_WRF. When I installed NCEPlibs and then UPP4.1 the build completed and I have an executable. Now I need to try it out.