Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Problem with LANDMASK values [SOLVED]

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Georgii Nerobelov

New member
Hello Sir/Madam.

At first, preprocessing and running of the model are going well. But few days ago I`ve expanded modelling domain. Then, almost accidentially, I noticed one strange thing in values of a LANDMASK variable inside new generated wrfinput file. The land fraction (value 1) appeared to be in a place where water fraction (value 0) had to be (see Pictures LANDMASK_geo_em_CORRECT.jpg,LANDMASK_wrfinput_INCORRECT.jpg and gulffin.gif as a reference map). The stranger thing is that "geo_em" and "met_em".. files included the correct LANDMASK variables. The issue appears after running "real.exe". The values of LANDMASK somehow changes during the "real.exe" run. The positions of the water and land surfaces look almost similar in wrfinput and geo_em (or in met_em) except for this noticeble part of land surface in the water where it is not expected to be. I tried a lot of approaches in handling the issue - I made domain smaller and greater, decreased and increased space step but nothing of this really helped.
I`ve attached pictures of the "geo_em" (correct) and "wrfinput" (incorret) LANDMASK, logs of "geogrid" and "real.exe" runs ,,, namelist.wps and namelist.input.
Probably for someone it looks as a minor inaccuracy but since I`m working with the regional and even urban scale modelling it is qute important to provide true data for the water and land surfaces.
I appretiate any help/advise in combating the issue!

Georgy Nerobelov.


  • real.exe.log.txt
    44.1 KB · Views: 52
    10.3 MB · Views: 52
  • geogrid.log.txt
    13.8 KB · Views: 56
  • namelist.input.txt
    7.3 KB · Views: 52
  • namelist.wps.txt
    1.3 KB · Views: 57
  • LANDMASK_wrfinput_INCORRECT.jpg
    117.9 KB · Views: 629
  • LANDMASK_geo_em_CORRECT.jpg
    119.3 KB · Views: 628
  • gulffin.gif
    24.3 KB · Views: 625
Ok,the problem has been solved. The issue was connected to GFS NCEP 0.25deg analysis files which I used as ic and bc for meteorology. I had replaced it with 0.5deg GFS dataset and the problem was resolved.