Problem with SEVIRI radiance assimilation in WRFDA - version 3.9.1 AND 4.1.5

This post was from a previous version of the WRF&MPAS-A Support Forum. Please do not add new replies here and if you would like the thread moved out of the Historical / Archive section then contact us, making sure to include the link of the thread to be moved.

detlef

New member
Dear All,
when I try to assimilate SEVIRI files (from NCEP GDAS Satellite Data - ds735.0) I have this problem (from rsl.out.0000):

WARNING FROM FILE: da_read_obs_bufrseviri.inc LINE: 299
Unknown platform: 70


This occurs with MSG1, 2 and 3.
I read that, in previous WRFDA versions, there is a (fixed) bug (source: http://www2.mmm.ucar.edu/wrf/users/wrfda/updates-3.9.html).
(solution: de-allocations of several variables are moved from outside of do-loop to inside).

But the new version of the file "da_read_obs_bufrseviri.inc" appears correct and the bug fixed.
Any suggestion for me ?
Thanks !
D.
 

hclin2018

New member
Platform ID 70 is for Meteosat-11, aka MSG-4.
The new satellite is not implemented in WRFDA.
You will need to modify the WRFDA code yourself.
 

detlef

New member
hclin2018 said:
Platform ID 70 is for Meteosat-11, aka MSG-4.
The new satellite is not implemented in WRFDA.
You will need to modify the WRFDA code yourself.

I tried to understand how and where to make the changes. But I did not succeed.
Can you give me more detailed information on the files to be modified?
Many thanks !
 

detlef

New member
detlef said:
Dear All,
when I try to assimilate SEVIRI files (from NCEP GDAS Satellite Data - ds735.0) I have this problem (from rsl.out.0000):

WARNING FROM FILE: da_read_obs_bufrseviri.inc LINE: 299
Unknown platform: 70


This occurs with MSG1, 2 and 3.
I read that, in previous WRFDA versions, there is a (fixed) bug (source: http://www2.mmm.ucar.edu/wrf/users/wrfda/updates-3.9.html).
(solution: de-allocations of several variables are moved from outside of do-loop to inside).

But the new version of the file "da_read_obs_bufrseviri.inc" appears correct and the bug fixed.
Any suggestion for me ?
Thanks !
D.

Sorry if I come back to the same issue...
I also tried with version 4.1.5 of WRF. And the same error appears.
Would anyone know how to help me?
Could it be a problem with the CRTM coefficients?

thanks!
 
Top