Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

real.exe segmentation fault with complex chemistry (112-mozcart or 132-CB05 with MADE)

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I am a new user of WRF-Chem and from a past few days. I am struggling to run real.exe when I enable mozcart chemistry (112).
real.exe crashes with segmentation fault.
It runs successfully with rather simpler chemistry (e.g. 1- RADM2 with no aerosol or 13).
I am running it on a supercomputer (with ~196GB ram and unlimited core dump size).
I have tried to work with both WRF-Chem version 3.9.1 and 4.2 but no success.
For your reference, I have attached my namelist.input and rsl.error with a debug option set to 100 (for WRF-Chem version 4.2).
Any leads will be highly appreciated.

Best regards,


  • namelist.input
    6 KB · Views: 41
  • rsl.error.0000.txt
    29.6 KB · Views: 37
  • rsl.out.0000.txt
    35.9 KB · Views: 34

It looks like you are only running real with 1 processor? Please try running with with more (8 would be a good start). If the same error persists, please try to compile with the debug option and rerun so we can do the traceback.

Hi Jordan,
Thanks a lot for your reply. I also tried running with 16 processors, but still the problem persisted. I still do not understand the problem, but managed to solve the issue somehow.
Earlier I compiled using gfortran and I did a clean -a and performed a fresh compilation using intel compilers.
After that, I did not face this issue.

Thanks again for your kind support.

Best regards,
Hi Vinod,

I'm glad you fixed it with the intel compiler. If you could please post which versions of the gfortran and intel compilers you tested that would be helpful for users that may experience the same issues. Thanks!

I was using GNU Fortran (GCC) 10.2.0.

When compiled using ifort (IFORT) 20200925, i did not see this problem.

Best regards,