Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

real.exe segmentation fault with complex chemistry

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hello all,

I have installed WRF-Chem v4.3 using the installation script. I am struggling to run real.exe when I enable mozcart or mozcart-mosaic chemistry.
real.exe crashes with a segmentation fault. Without the chemistry option turned on everything works fine. I tried to installed WRF-Chem v4.2.2 and v4.1.1 as well. But in every installation this problem persists.

I would love to get any help possible.



  • configure.wrf
    20.5 KB · Views: 36
  • log.compile
    2 MB · Views: 36
  • rsl.error.0000.txt
    2 KB · Views: 42
  • namelist.input
    7.9 KB · Views: 44
Hi, I have the same problem. Did you solve in same way? About the number of processor I tried, from 1 to 1200... I do not think is something related to the pc/cluster ability.

Is there any additional information in rsl.out/error when you set debug_level = 300? What about a different chemical mechansim (e.g., 300)?