Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) geogrid error (invalid memory)

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


I am trying to run geogrid.exe but having an error below:
mpirun -np 6 ./geogrid.exe
Parsed 25 entries in GEOGRID.TBL
Processing domain 1 of 1
Processing XLAT and XLONG

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x100a0f6fd
#1 0x100a0ea93
#2 0x7fff7246cb3c

Hope help and/or guidance to solve this.
Which version of the WPS and WRF codes are you using? Also, which compiler and compiler version are you using? Do you see the same error if you run the geogrid program in serial?
I am using 3.9, had the same error when using serial. I tried the same config with 4.0.3 but wonder if the generated met files will work with 3.9?
Which compiler and compiler version are you using? If you happen to be using the Intel compilers, you could try unlimiting the stacksize with either "ulimit -s unlimited" or "limit stacksize unlimited", depending on your shell. The Intel compilers tend to aggressively allocate memory on the stack, which can cause default stack size limits to be exceeded.
I recompiled my WPS and it worked with 3.9. Now I wanted to use the same namelist.input in 4.0.3 but it did not work:

ERROR: MMINLU values differ among input fields. Reading LANDUSEF using entry 3 from GEOGRID.TBL did not set mminlu, and thus the default value of USGS is assumed. However, mminlu was previously set to MODIFIED_IGBP_MODIS_NOAH

I think I'll keep my simulation with 3.9!