Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Running WPS in external disk - ungrib error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hello everybody,

As written in the title, I was trying to run WRF & WPS in an external disk of my laptop. Everything was fine until I had to run "ungrib.exe", which returned me the following error:

"At line 147 of file output.f90 (unit = 13)
Fortran runtime error: Cannot open file '/../../../../../media/federico/Data/AgroSoc/ungribfiles/PFILE:2021-07-31_18': Invalid argument

Error termination. Backtrace:
#0 0x7f51db4fed21 in ???
#1 0x7f51db4ff869 in ???
#2 0x7f51db50054f in ???
#3 0x7f51db73f9d6 in ???
#4 0x7f51db73fccc in ???
#5 0x560dd55d41cf in ???
#6 0x560dd55d2ac1 in ???
#7 0x560dd55d3112 in ???
#8 0x7f51db1a90b2 in ???
#9 0x560dd55cc7dd in ???
#10 0xffffffffffffffff in ???"

Following the suggestion contained in this topic:, I ran ungrib in my home directory and everything turned fine again. The problem is that I don't have enough space in my home disk and I would like to run WRF in the external one. Is there any suggestion to bypass that bug?

Thank you,
Not really an answer, but I think this might be due to encoding of the external disk filesystem hence the question marks.
Are there any special characters?
maybe you have annother external just to test?
Well, thank you because you gave me the input to find the issue. I formatted an external disk and tried different file systems. The only that finally worked was the Linux partition one. Thank you again.