Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(SOLVED) WRF 4.2.1, real.exe immediate segmentation fault

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I recently compiled WRF4.2.1 and WPS 4.2. I'm using CCSM4 data for BC and IC and keep getting an immediate segmentation fault when I run real.exe. The only output in the rsl files is "module_io_quilt_old.F 2931 T".
View attachment namelist.input
View attachment rsl.tar
I was able to successfully run real.exe in WRF4.0.1 using the same namelist and met_em files, so I don't think the issue is in either my namelist or WPS processing. Any suggestions would be greatly appreciated!

The only thing I see is that you're missing a coma after the smooth option.
The default output should be:
Quilting with   1 groups of   0 I/O tasks.
I've never had this error, but I think the main problem might be with the compiler. I would check first if the configure options are ok for the compiler you are using, and if you are using some options that might not be compatible when you are running wrf.
mpirun [options] -n 8 ./wrf.exe
This is weird that 4.1 is OK and 4.2 is problematic. There are two ways to proceed:
1. Say the heck with v4.2 real, as the v4.1 real works just great for WRF.
2. Roll up your sleeves.

Rolling up your sleeves

Let's try to see if we can get any additional information from the failed run of the real program.

Go back and rebuild the WRF model.
./clean -a
./configure -D

The "-D" option says to remove optimization, allow tracebacks, notify incase of bound errors, trap floating errors, check for uninitialized variables (at least some of them), etc.

When you make the executable, do a serial build (not DM parallel - NOT with MPI). For Linux + Intel, that would be
./compile << EOF
This will run slowly, but the code dies nearly instantly anyways, so no troubles. Remember that once the code is working, you need to rebuild this really slow executable! Also, since the code dies really fast, run this executable interactively on an interactive login node (do not send it into a queue).

Don't send the output to a file, just take a look at what ends up on the screen.
Thanks for the suggestions! I am using Linux + Intel, but for some reason, I am not able to compile in serial. Building WRF in parallel (option 15) still works fine though. Does this make any sense?
Can you post the output of the failed build log that is generated when trying to build the code serially?
Thanks for the tips Dave! While digging through the build log I remembered I made some changes to my environment a few months ago and wasn't loading MPICH2. Fixed my libraries and all is working as expected.