Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

The cold and 'drying' effect of radiance data assimilation

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


Dear Colleges,

The assimilation of satellite radiance consistently produces colder temperatures and convective precipitation decrease in my wrf forecasts!

I am trying use satellite radiance and humidity in my convective-permitting simulations. I have experimented a lot with different background options (CV3, CV5, CV7), length scale, variance, thinning, VARBC options, etc. I have applied satellite data assimilation to the first guess field derived from both wrf initial condition fields (wrfinput) and WRF forecasted fields (wrfout).
After data assimilation there is a well-defined tendency of temperature decrease and reducing precipitation amounts over my simulation domains for all cases. These data assimilation effects are becoming more and more enhanced when I use cycling data assimilation and assimilate satellite data more than once (e.g. at 00, 06, 12 UTC).

For some cases disappearing of the precipitation areas are 'good', since over the mountain areas the WRF simulates false (spurious) convective precipitations. However, 'correctly' simulated areas also disappear after data assimilation. For example, the local heavy rainfall area of interest successfully simulated by the WRF model disappears after data assimilation.

I am attaching my namelist file. Is anything wrong with it? Can you explain the reasons for this issue?

Best regards,


  • namelist.txt
    3.9 KB · Views: 131
Hello Artur,
It would be helpful to see your detailed results and methodology. Without further knowledge, may I ask if you are using any sort of cloud detection filter? Many radiance instruments/channels are affected by clouds, which generally produces colder brightness temperatures. There is a wealth of literature discussing this topic. The observation error needs to be adjusted to properly handle those situations, or else the affected pixels should be removed.

Thanks for your reply!
I am still trying to understand what causes this issue. I do not think that this is caused by data assimilation.
I am attaching two maps of simulated temperature: one at the forecast starting time (T2_d02_20180810_00_00_00.jpg) and the other at the first forecasting step, after 5 min (T2_d02_20180810_00_05_00.jpg). You can see that at the first forecasting step the temperature becomes notably colder over the simulation domain. Please, also pay to attention to the sharp temperature change zone over the eastern boundary of the domain. I applied satellite data assimilation only for d02 domain at 0000 UTC, 10 Aug (shown in figures). So, I did not change my wrfinput_d01 and wrfbdy_d01 files when running the wrf.exe. I only replaced the wrfinput_d02 file by the wrfvar_output file. In other word, the problem occurs at the first forecast step and later after running the wrf.exe. I use WRF v4.0 and WRFDA v4.0. Please, find attached my namelist input file as well.

Best regards,


  • namelist.txt
    6.3 KB · Views: 116
  • T2_d02_20180810_00_00_00.jpg
    303.2 KB · Views: 5,801
  • T2_d02_20180810_00_05_00.jpg
    358.3 KB · Views: 5,801
Artur, it sounds like from your description that the images are for d02 only (the inner domain). What are the resolutions of d01 and d02. In addition to the fast T2 changes you noted, there is a very severe smoothing in that first time step. This is all a little outside my area of expertise. I would suggest dual-posting in the WRF section of the forum and referencing this thread.

Just to clarify, is the smoothing and magnitude change of T2 only happening in the first time step when data assimilation is used? Or does it also happen when data assimilation is not used?

The issue was solved with application of older versions of WRFDA (3.9 and 3.9.1). Now, you can see that the T2 (2-meter temperature) map looks fine without any abrupt changes in T2 over the simulation domain. Furthermore, the satellite humidity is successfully assimilated. You can see that QVAPOR at 28th model level is evidently increased over some areas (marked with circles) after data assimilation. Therefore, I assume that it is the WRFDA issue. I have posted the similar problem for radar data assimilation when using WRFDA 4.0 and 4.1 ( Again, the issue was solved with using WRFDA 3.9 and 3.9.1.
I assume that the problem is associated with inproper processing of moist potential temperature which is default option since WRF v 4.0. However, it is stated that "3DVAR and hybrid-3D/4DEnVar now work with moist potential temperature" at

It is little bit complicated to use wrfvar_output file from WRFDA v3.9 with WRF v 4.0 and later model releases because the WRF model first complains that

This input data is not V4: OUTPUT FROM WRFDA V3.9
You can try 1) ensure that the input file was created with WRF v4 pre-processors, or
2) use force_use_old_data=T in the time_control record of the namelist.input file

Then, after adding force_use_old_data=T, the WRF complains

---- ERROR: Cannot have old input data when requesting use_theta_m=1

So, I have to manually edit the title of my wrfvar_output file from WRFDA v3.9 (in global attributes) and then use that for running the WRF in order to avoid the above issues.
I change the

// global attributes:

overwritten by the WRFDA 3.9 to

// global attributes:

If you need further output information or namelist files from running the WRFDA 3.9 vs WRFDA 4.0 for this single case, please let me know.



  • QVAPOR_d02_2018-08-10_00_05_00.jpg
    343.4 KB · Views: 2,352
  • QVAPOR_d02_2018-08-10_00_05_00_WITHOUT_DA.jpg
    337.3 KB · Views: 2,352
  • T2_in_d02_2018-08-10_00_05_00.jpg
    342.3 KB · Views: 2,352
WRFDA 3D-Var and Hybrid 3DEnVar only work with moist theta since WRF v4.1, which is where that release note is posted. Were you using v4.0 or v4.1? Would you mind trying v4.1.2? That is the latest tagged release of WRF/WRFDA.

I tried both with WRFDA V4.0 and V4.1. Yes, I also used moist theta. I will also try with v4.1.2 and report about the results.

I am glad to tell you that the WRFDA v4.1.2 successfully assimilates both satellite and radar data.
Thanks a lot for your help!