Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

The problem in WRF 4.3.1 compilation

Naser

Member
Hello everyone

I am trying to compile WRF4.3.1. But does not make any *.exe file.
You can find my configure.wrf and log.compile in the attachment.

I am looking forward to your answer

Thank you
Naser
 

Attachments

  • configure.wrf.txt
    23.5 KB · Views: 1
  • log.compile.txt
    986 KB · Views: 0
These two posts might help you.


 
Hello Will

Thanks for your kind response.
Actually, my environment is good, I think. I used this test, and the result was acceptable.
Second, I compiled WRF3.9.1 before with this environment; it worked.(I just changed some parts in configure.wrf).
now I want to update my WRF to 4.3.1, but I don't know how can I fixed errors. I this I have to change my configure.wrf. But I don't know how can I understand which part must be changed.

Do you have any idea about changing configure.wrf?

Thanks Naser
 
Hello Will

Thanks for your kind response.
Actually, my environment is good, I think. I used this test, and the result was acceptable.
Second, I compiled WRF3.9.1 before with this environment; it worked.(I just changed some parts in configure.wrf).
now I want to update my WRF to 4.3.1, but I don't know how can I fixed errors. I this I have to change my configure.wrf. But I don't know how can I understand which part must be changed.

Do you have any idea about changing configure.wrf?

Thanks Naser
If you are going to install v4 of WRF I would recommend using the the current version v4.4.2 (GitHub - wrf-model/WRF: The official repository for the Weather Research and Forecasting (WRF) model)

Looking at your configure.wrf file the only thing I see that might be the issue is lines 170 and 171

DM_FC = mpif90 -f90=$(SFC)
DM_CC = mpicc -cc=$(SCC)

I personally have always changed them to this

DM_FC = mpiifort
DM_CC = mpiicc

Also have to do the same thing for configure.wps

And then use option 15 for WRF under the configure command
And then use option 19 for WPS under the configure command.
 
Hello Will

Thank you.

Unfortunately, it does not work again. I personally apply these changes in my configure.wrf for compilation WRF3.9.1:
1680577667513.png
but these are not working with 4.4.2.
I used your Idea, does not work.
So, now I am trying to compile without any changes. I will upload the result in the group chat.

Thanks
 
Top