Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Why do WRFV4.2.2 taking more computational time when compared to WRFV4.0?

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I have used WRFV4.0 in my laptop with Ubuntu 18.04 using 12gb ram (not an mpirun) 2 years back to simulate thunderstorm cases. The domain configuration was 9:3:1 with 399 grid points in east west and 429 grid points in south north direction with with a timestep of 45 seconds for domain 1. where as 250 and 331 grid points were there for 2nd 3rd domains in east west direction. The simulation was carried for 24 hrs and it took around 36 hours then.

Today i ran a different case for 30hours with a comparatively same domain resolutions (9:3:1), but less grid points (281in WE and 220 in SN for domain 1) using the similar parametrization schemes in WRFV4.2.2 in an hpc with 32 cores mpirun. It was surprising that the model was unstable with 45seconds time step and i had to reduce it to 36!! (the error was bad termination with exit code 8). then, it is took 4 hours to integrate for 15minutes out of 30hours. when we calculate from this, the approximate time the model will take to complete 30hours simulation is 480hours (20 days!!!).

How is this possible?? That is also with smaller domain with 32 cores parallel running. Please help me in this regard. am sure iam wrong in some point using this HPC.

The major changes are
WRFV4.0 WRFV4.2.2
no chem compiled compiled with chem
no KPP enabled enabled with KPP
using 12gb ram in laptop using 32 cores in HPC
ubuntu 18.04 Cent OS 7.5.1511
timestep: 45 36
runtime: 24 30
e_we : 399,250,331 281,367,331

radiation : New Goddard RRTMG
land surface : Noah Noah MP
same Microphysics (milbrant)
same cumulus scheme (BMJ)
same pbl (MYJ)
same sfclay(Eta similarity)

I tried to run WRFV4.2.2 in laptop, but it is giving memory error.

Thanks in advance.
Thank you Jordan for your reply. Without chemistry, model works fine. I had to recompile the model without chemistry.