Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF-Chem tendency diagnostics for chemistry

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi all,

I ran my simulation with chemdiag=1. But I cannot find the diagnostics (such as conv_o3, chem_o3, vmix_o3, etc.) in my wrfout files. I am wondering is there any other thing I need to do to enable the output of chemical diagnostics? Thank you!

Best regards,
Hi Bessie,
I also encountered the same problem when running WRF-Chem v4.0. Has your problem been solved? Could you please give me some suggestions?Thank you.

Best regards,
Hi Bessie and Ruixin,

You can output those variables in one of two ways -

option a)
1. Run "./clean -a"
2. add an "h" the variables in Registry/registry.chem that you want output (.e.g., change this:
state real chem_co ikjf chem_ct 1 - r "chem_co" "ACCUMULATED CHEM TENDENCY FOR CO" "ppmv"
to this:
state real chem_co ikjf chem_ct 1 - rh "chem_co" "ACCUMULATED CHEM TENDENCY FOR CO" "ppmv"
3. Recompile the model

option b)

Add a custom i/o fields file (see the WRF-Chem user guide) to your run directory and set in your namelist.


Thanks for your help,I have successfully output these variables!

Best regards,