Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRFDA 4dvar segmentation fault in tutorial


New member
Hello, I have been working through the WRFDA tutorial ( All the examples I tried went fine until trying to run the 4dvar case, at which point I just get a mysterious segmentation fault:

"Program received signal SIGSEGV: Segmentation fault - invalid memory reference."

I attached the relevant error and log files.




  • var4d.log
    565 bytes · Views: 105
  • rsl.error.0000.txt
    10.9 MB · Views: 108
  • rsl.out.0000.txt
    10.9 MB · Views: 99
  • compile_4dvar.log
    552.6 KB · Views: 84
  • configure.wrf
    20.2 KB · Views: 94
  • namelist.input.txt
    1.9 KB · Views: 100

Were you able to solve this? I have a similar issue on the example tutorial in the documentation. I encountered CFL errors and tried to:
a) reduce the time step
b) use damping
c) use smooth_cg_topog
d) use epssm

but non of the above solved the issue. Please let me know if you were able to figure this out!
It looks like the problem occurs when using the surface layer parametrization. try different setting in namelist of sf_sfclay_physics=.., maybe 4.
I also have the same problem. Tried everything mentioned here, including changing sf_sfclay_physics and even other physics options.
Did not work, still getting Segmentation fault. Any other suggestions are appreciated!
I am working on WRF 4.4 with the option in &time_control that enables to use older-version data (force_use_old_data=.true.) as the most recent available tutorial is 3.9 from WRFDA - Test Data Sets

(3dvar example also works fine for me)