Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRFPLUS 4.3.3 compilation errors

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Feng Liu

New member
Hello WRF community and users,

I downloaded the latest version of WRF 4.3.3 system and try to run WRFDA/4DVAR. So I need to compile WRFPLUS first. However, I failed to compile WRFPLUS successfully due to the following error:

PGF90-F-0000-Internal compiler error. gen_llvm_expr(): unknown opcode 411 (module_cu_gf_deep.f90: 3367)
PGF90/x86-64 Linux 19.3-0: compilation aborted
rm -f module_cu_ksas.G
0.91user 0.06system 0:00.97elapsed 99%CPU (0avgtext+0avgdata 25416maxresident)k
0inputs+18768outputs (0major+22853minor)pagefaults 0swaps
make[3]: [module_cu_gf_deep.o] Error 2 (ignored)

I could not get any clue when looked at line 3367 in module_cu_gf_deep.f90

3367 do k=kts,ktf
3368 do i=its,itf
3369 pw(i,k)=0.
3370 pwh(i,k)=0.
3371 qc(i,k)=0.
3372 if(ierr(i).eq.0)qc(i,k)=qe_cup(i,k)
3373 if(ierr(i).eq.0)qch(i,k)=qe_cup(i,k)
3374 clw_all(i,k)=0.
3375 clw_allh(i,k)=0.
3376 qrc(i,k)=0.
3377 qrcb(i,k)=0.
3378 enddo
3379 enddo

I actually had the same issue with previous WRF 4.3. I tried multiple options to compile WRFPLUS but in vain. I am looking forward to your help and any ideas to fix the problem.

Two possible solutions for "Internal compiler error":
1. reduce the optimization level to -O2 or -O1
2. use a different version of compilers
Hello, hclin2018,

Thank you for the reply.

I tried to compile WRFPLUS 4.3.3 with FCOPTIM -O2 and -O1, respectively, The compilation with option -O2 failed. I got wrfplus.exe with -O1 and successfully compiled WRFDA 4dvar. However, I got "Segmentation fault (core dumped)" when I ran WRFDA/4dvar.

There is nothing wrong in rsl.error.0000 and rsl.out.0000. I do not know how to fix it.

I agree with you that we may need to upgrade compilers.