wrf.exe crash when using the new GEFS 0.5 data

Topics specifically related to the wrf.exe program
Post Reply
hrabah
Posts: 1
Joined: Mon Sep 28, 2020 6:30 pm

wrf.exe crash when using the new GEFS 0.5 data

Post by hrabah » Tue Sep 29, 2020 3:53 pm

Hello Wrfhelp,

We used GEFS 1 deg to initialize WRF V4.1.2 and it works for months without any problem.
However when those data are replaced by GEFS 0.5 deg WRF starts to crash and returns the error which obviously related to the lw_physics schema.

we are using those data :
gep01.t00z.pgrb2b.0p50.fXXX
gep01.t00z.pgrb2a.0p50.fXXX
from : https://nomads.ncep.noaa.gov/pub/data/n ... /00/atmos/
You can find attached the namelists and Vtable used for this run as well as logs from ungrib.exe and metgrid.exe
Thank you for your help
Rabah

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x7F738D040697
#1 0x7F738D040CDE
#2 0x7F738C53B3AF
#3 0x1C62C50 in __module_ra_rrtm_MOD_taugb3
#4 0x1C64B1A in __module_ra_rrtm_MOD_gasabs
#5 0x1C78CBB in __module_ra_rrtm_MOD_rrtm
#6 0x1C7DE08 in __module_ra_rrtm_MOD_rrtmlwrad
#7 0x17907D0 in __module_radiation_driver_MOD_radiation_driver
#8 0x187CD64 in __module_first_rk_step_part1_MOD_first_rk_step_part1
#9 0x12404D0 in solve_em_
#10 0x1119D55 in solve_interface_
#11 0x4759F0 in __module_integrate_MOD_integrate
#12 0x407C53 in __module_wrf_top_MOD_wrf_run
Attachments
Vtable.txt
(4.58 KiB) Downloaded 10 times
ungrib.log
(422.01 KiB) Downloaded 6 times
rsl.out.0000.log
(301.92 KiB) Downloaded 9 times
rsl.error.0000.log
(3.76 KiB) Downloaded 5 times
namelist.wps
(734 Bytes) Downloaded 6 times
namelist.input
(4.8 KiB) Downloaded 6 times
metgrid.log
(552.81 KiB) Downloaded 5 times

rschumac
Posts: 2
Joined: Thu Oct 01, 2020 5:55 pm

Re: wrf.exe crash when using the new GEFS 0.5 data

Post by rschumac » Fri Oct 02, 2020 4:53 pm

I just wanted to add a +1 to this post, as I'm having the exact same issue as reported here when initializing WRF with the new GEFS data. geogrid, metgrid, and real.exe all appear to work properly, but then wrf.exe throws a segfault sometime within the first timestep.

kwerner
Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: wrf.exe crash when using the new GEFS 0.5 data

Post by kwerner » Mon Oct 05, 2020 2:56 pm

Hi,
Thanks for brining this to our attention. A fix for this problem can be found here: https://github.com/wrf-model/WPS/pull/158
You should see the explanation, and then if you click on the "Files changed" tab, you should see the file modification. Let me know if you have any questions.
NCAR/MMM

rschumac
Posts: 2
Joined: Thu Oct 01, 2020 5:55 pm

Re: wrf.exe crash when using the new GEFS 0.5 data

Post by rschumac » Thu Oct 08, 2020 7:34 pm

This fix solved my problem - thanks! I just recompiled ungrib.exe with this update and things are now running successfully.

kwerner
Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: wrf.exe crash when using the new GEFS 0.5 data

Post by kwerner » Fri Oct 09, 2020 9:39 pm

Great! Thank you for updating the post.
NCAR/MMM

Post Reply

Return to “wrf.exe”