Failure while running wrf.exe

Topics specifically related to the wrf.exe program
Post Reply
ichigosihebat
Posts: 5
Joined: Tue Dec 29, 2020 9:26 am

Failure while running wrf.exe

Post by ichigosihebat » Mon Jan 04, 2021 9:20 am

Hello everyone,
I faced problems when running wrf.exe
Previously, I ran the real.exe and suddenly the program was killed due to signal 9.
Therefore, I reduce the size of the domain. Somehow, then, I successfully ran the real.exe. However, when I ran the wrf.exe, the program had stopped itself and generated 2 wrfout files at 2 domains, but only produced at time = 0. I checked the wrf.log and there's no error.
Would you mind helping?
Thank you in advance
Best Regards,
Nizam

Ming Chen
Posts: 1290
Joined: Mon Apr 23, 2018 9:42 pm

Re: Failure while running wrf.exe

Post by Ming Chen » Tue Jan 05, 2021 5:10 pm

Please provide more information about this failed case:
(1) which version of WRF did you ru?
(2) How did you compile and run WRF?
(3) what data did you use to drive WRF?
(4) Please upload your namelist.input for me to take a look.
WRF Help Desk

ichigosihebat
Posts: 5
Joined: Tue Dec 29, 2020 9:26 am

Re: Failure while running wrf.exe

Post by ichigosihebat » Sat Jan 16, 2021 9:08 am

1) I ran the WRF 4.2
2) I compiled using gfortran and gcc and previously I set the environment with enabled netcdf using hdf5
3) I used GFS grib2 data
I attach this reply with namelist.input
Attachments
rsl.out.0001.log
(4.13 KiB) Downloaded 3 times
namelist.input
(4.58 KiB) Downloaded 5 times

Ming Chen
Posts: 1290
Joined: Mon Apr 23, 2018 9:42 pm

Re: Failure while running wrf.exe

Post by Ming Chen » Wed Jan 20, 2021 9:51 pm

It seems that this case failed immediately after wrf.exe started. However, there is no error information in the rsl file you attached. Note that error message may appear in any of the rsl files. Please double check all the rsl files and find possible error information, which is very important for us to trace what is wrong.
For your namelist, I have a few suggestions:
(1) time step should be 6 times of grid interval. For your case, 3km should use time step of 18
(2) for dx = 3km and 1km, cumulus scheme should be turned off
(3) radt should be equal to dx, and in this case it should be 3 instead of 30
(4) please set w_damping =1

Please rerun this case and let me know if you still have problems.
WRF Help Desk

Post Reply

Return to “wrf.exe”