Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Failure while running wrf.exe

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hello everyone,
I faced problems when running wrf.exe
Previously, I ran the real.exe and suddenly the program was killed due to signal 9.
Therefore, I reduce the size of the domain. Somehow, then, I successfully ran the real.exe. However, when I ran the wrf.exe, the program had stopped itself and generated 2 wrfout files at 2 domains, but only produced at time = 0. I checked the wrf.log and there's no error.
Would you mind helping?
Thank you in advance
Best Regards,
Please provide more information about this failed case:
(1) which version of WRF did you ru?
(2) How did you compile and run WRF?
(3) what data did you use to drive WRF?
(4) Please upload your namelist.input for me to take a look.
1) I ran the WRF 4.2
2) I compiled using gfortran and gcc and previously I set the environment with enabled netcdf using hdf5
3) I used GFS grib2 data
I attach this reply with namelist.input


  • namelist.input
    4.6 KB · Views: 46
  • rsl.out.0001.log
    4.1 KB · Views: 40
It seems that this case failed immediately after wrf.exe started. However, there is no error information in the rsl file you attached. Note that error message may appear in any of the rsl files. Please double check all the rsl files and find possible error information, which is very important for us to trace what is wrong.
For your namelist, I have a few suggestions:
(1) time step should be 6 times of grid interval. For your case, 3km should use time step of 18
(2) for dx = 3km and 1km, cumulus scheme should be turned off
(3) radt should be equal to dx, and in this case it should be 3 instead of 30
(4) please set w_damping =1

Please rerun this case and let me know if you still have problems.
Hello Meng.
Did you eventually solve this problem?
I tried the solution you suggested but it did not work.

I kindly ask for some help to solve this.


  • namelist.input
    5.9 KB · Views: 24