(RESOLVED) plotgrids permission denied error

Topics related to the utilities available in the WPS/util/ directory
Post Reply
ggp17mkm
Posts: 20
Joined: Fri Oct 25, 2019 2:47 pm

(RESOLVED) plotgrids permission denied error

Post by ggp17mkm » Mon Aug 10, 2020 5:39 pm

Hi,

I used this command ncl util/plotgrids.ncl to check my domain's locations before running ./geogrid.exe. I got this error:
bash: ncl: command not found

Any suggestion please? Am a new user of WRF, climate modelling, etc.

kwerner
Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: Error for visualising domain

Post by kwerner » Tue Aug 11, 2020 11:04 pm

Hi,
Do you have NCL installed? If not, take a look here: http://www.ncl.ucar.edu/
Make sure to download and install the pre-built binaries, and do not try to install from scratch.

If you have it installed, it may be that you just need to point to the binary in your path, and you'll also need to set the NCARG_ROOT environment variable. This presentation about NCL may also have some useful information for getting things set up:
https://www2.mmm.ucar.edu/wrf/users/tut ... ye_ncl.pdf
NCAR/MMM

ggp17mkm
Posts: 20
Joined: Fri Oct 25, 2019 2:47 pm

Re: Error for visualising domain

Post by ggp17mkm » Fri Aug 21, 2020 12:14 pm

Hello,
I have installed ncl 6.5.0

After issuing ncl -V, I get 6.5.0 as confirmation of setting correct paths etc.
Now when I run the command ncl util/plotgrids.ncl for checking my domain configurations for WRF(as suggested on the ARW tutorial), I get the response You need NCL V6.1 to run this script. Try running util/plotgrids_new.ncl

So I ran: util/plotgrids_new.ncl
In response I get : permission denied.

Could you please guide on whats going on? Many thanks.

kwerner
Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: Error for visualising domain

Post by kwerner » Fri Aug 21, 2020 4:42 pm

Hmm, that's odd. Try to move the util/plotgrids_new.ncl file to your current WPS directory to issue the ncl command. Then just issue:

Code: Select all

ncl plotgrids_new.ncl
If that doesn't work, send me the output you're getting on the screen.
NCAR/MMM

ggp17mkm
Posts: 20
Joined: Fri Oct 25, 2019 2:47 pm

Re: Error for visualising domain

Post by ggp17mkm » Tue Nov 03, 2020 11:21 pm

Hi,
Just to let know your suggested solution has worked. Many thanks Kelly :-)

kwerner
Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: Error for visualising domain

Post by kwerner » Wed Nov 04, 2020 12:02 am

That's great news! Thanks for letting me know.
NCAR/MMM

Post Reply

Return to “WPS Utilities”