Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) plotgrids permission denied error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I used this command ncl util/plotgrids.ncl to check my domain's locations before running ./geogrid.exe. I got this error:
bash: ncl: command not found

Any suggestion please? Am a new user of WRF, climate modelling, etc.
Do you have NCL installed? If not, take a look here:
Make sure to download and install the pre-built binaries, and do not try to install from scratch.

If you have it installed, it may be that you just need to point to the binary in your path, and you'll also need to set the NCARG_ROOT environment variable. This presentation about NCL may also have some useful information for getting things set up:
I have installed ncl 6.5.0

After issuing ncl -V, I get 6.5.0 as confirmation of setting correct paths etc.
Now when I run the command ncl util/plotgrids.ncl for checking my domain configurations for WRF(as suggested on the ARW tutorial), I get the response You need NCL V6.1 to run this script. Try running util/plotgrids_new.ncl

So I ran: util/plotgrids_new.ncl
In response I get : permission denied.

Could you please guide on whats going on? Many thanks.
Hmm, that's odd. Try to move the util/plotgrids_new.ncl file to your current WPS directory to issue the ncl command. Then just issue:
ncl plotgrids_new.ncl
If that doesn't work, send me the output you're getting on the screen.
Hi Kelly,
As from my previous posts, ncl for domain viewing was working perfectly. Now out of the blue I am getting these errors:

Warning: Unable to load system resource file NCL/lib/ncarg/sysresfile
Warning: WorkstationClassInitialize: Unable yo access rgb color database - named colors unsupported: [errno=2]
fatal: Could not open (NCARG_Root/lib/ncarg/nclscripts/csm/gsn_code.ncl)
fatal: error at line 7 in file plotgrids_new.ncl