Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

0 values in WRF-Fire output variables

janac4

Member
Hello,
I have activated wrf-fire options in my wrf-arw model. Although new variables appear in geogrid, metgrid, wrfinput and wrfout files, simulation variables such as FIRE_AREA appear to be zero (I have checked and NFUEL_CAT and ZSF variables in geogrid file are correct). Also, my simulation breaks after short time without error message. Just once I got the error:
push_communicators_for_domain would exceed stacksize
Can someone help me with these issues?
 

Attachments

  • namelist.input
    6.7 KB · Views: 1
Hi,
I don't have any experience with running a wrf-fire simulation, but in looking around at some of the code and the Users' Guide, I see that the namelist variables "sr_x" and "sr_y" must be even numbers. You have them set to 5. I'm not sure if this is causing your issues, but can you change this to 4 or 6 and see if you can get any further? If the model still stops, will you package all of your error/out files (e.g., rsl.*) into a single *.tar file and share that file? Thanks!
 
Hello, thanks for your response.
I also tried using sr_x=sr_y=1, so the fire grid is the same as the domain's, but the model also cracks. I attach my namelists and out files in case you see anything strange. The model doesn't stop always at the same time, once I managed to get three wrfout files, but no more.

I also attach the terminal error:
HBDaN1SGVbB4uupGF82WDXpxq1BWyMgWkfppOcmFq5HTm7BAzNPDgAdjmDRMltzsYTeDDgJrB36Po2QhLTfJfSmIgFWQxYiGIV0ErT505er3ddfcbLgSY8QDk_dSvHeUftDDE3lUYuaLBWsUqvlk43k

And the ending of rsl.error.0000 when I got the longer message:
_0nZX68T-dBG2YjUbK3LLmAIp41gz8aG_E-GTC2wzT2K8AJ5KyGCZraYTavkuBrjJ6zjvf4qgX-qKt1G7uelvb-KyeN4AW1ZoPB-_RmecY2DTs2zEcUjSZ-xg3CfhucXGFm82B8GU1jdgRwCecBazJY
 

Attachments

  • tst-files.zip
    19.8 KB · Views: 1
Last edited:
Hi,
Did you also try setting sr_x and sr_y to an EVEN number (so, something like 2, 4, 6, 8, ....)? They need to be set to an even number, and 1 is not even.

I also see that you're only using a single processor for this simulation. Can you try to increase the number of processors you're using to see if that helps? Try something like 36.

When you say that it doesn't always stop in the same place, do you mean that if you run two identical simulations (i.e., you don't change anything in your namelist), the model may stop at different times? Or do you mean that when you make small changes to the namelist, the model stops at slightly different times?
 
Hello,
I have just tried setting sr_x=sr_y=2 but wrf.exe cracks anyway. I tried increasing the number of processors with "mpirun -np 8 --bind-to none --report-bindings ./wrf.exe" but it doesn't solve the problem.

Regarding the model stopping time, I'm relating to the first option: if I run two identical simulations (i.e., I don't change anything in your namelist), the model may stop at different times.
 
Thanks for trying that, and apologies for the delay in response. The fact that you can run two identical simulations and they stop in different spots seems to indicate an issue with the computation/environment.

In your first post, I believe the model was running fine, but you were just missing fire data. Is that correct? But now the model is failing if you set the sr* values to anything else? As a test, if you set those values back to the original values you were using (5), does the model still run to completion?
 
When I set ifire=0 the model runs without problems, since the FIRE module is diabled. When using ifire=1 the model runs but no fire output variables appear in the wrfouts. After setting ifire=2, I get wrfouts with fire variables but not a single time the model has run to completion (and the few wrfouts I get have fire variables = 0).
I'm gonna try to compile a newer WRF version to check if this is a computation/environment issue.
 
Top