Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Adaptative Time Step

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.



I am trying to use the adaptative timestep option but I am having trouble with it. What happens is that it runs but it finishes after computing the first hour (there are 72 to be done) without giving any error message. In fact, in the rsl.error.0000 appears the WRF success message at the end, so I do not understand what is happening here... Can anyone help me, please?

I have attached the namelist used.


  • namelist.input
    5.2 KB · Views: 64
You may be having a CFL error. Increase the debug to see if it prints any more information. Also, you have quite a few vertical levels; you also have to take that into account for the time step. Depending on the resolution and the number of vertical levels, I usually set the max_time_step between 3dx and 5dx. The min_time_step I typically use it at -1.
We did see this problem in older version of WRF. However, I believe this bug has been fixed.
Which version of WRF did you run? Can you try the newer version like WRFV4.3 and see whether you still have the same problem?
Hi! First of all, thank you so much for your reply and sorry for the delay!

Regarding the WRF version used, I am running WRFV4.3 so it seems that the problem persists in this case.
About the vertical levels, which number do you recommend?
Finally, what range of values of max_time_step and min_time_step do you choose depending on the vertical levels considered? Which is the best criterion?

Again, thank you so much!
I looked at your namelist.input. It seems that the issue is not related to adaptive time step. I wonder whether you have run this case with adaptive time step option off? Did it run to the end?

Please clarify whether this is a real-data case or an ideal case? if it is the latter, what ideal case did you run?
Hi! Thank you for your reply. It worked without the adaptive time step, for this reason I supposed that it was not working because of this option. Regarding the case, it is a real-data case.
Thanks for the update. Just one more issue: if this is a real-data case, then you should set p_top_requested instead of ztop. You may also need to set specified lateral boundary condition, i.e.,

spec_bdy_width = 5,
spec_zone = 1,
relax_zone = 4,
specified = .true., .false.,.false.,
nested = .false., .true., .true.,