Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Adaptive time step behavior: 3.8.1 vs 3.9

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I came across a change in behavior between WRF version 3.8.1 and 3.9 that I haven't seen posted anywhere.

When cycling WRF, I use the previous cycle's 'input_outname' wrf output files to initialize the next cycle (replace the next cycle's wrfinput_d<domain> file). I had done this with 'use_adaptive_time_step" = true with version 3.8.1.

When I do the same type of cycling procedure in WRF 3.9 however, WRF completes almost instantaneously. Checking the rsl.error.* files shows that the model "skips" the time step calculations and displays a 'SUCCESS COMPLETE WRF' at the bottom. If I turn off adaptive_time_step, it will complete as normal. If I replace the 'input_outname' type file with the standard 'wrfout_' file from the previous cycle while use_adaptive_time_step is true, the simulation completes normally.

Is this a bug or a planned change in model behavior? My workflow is designed to use the 'input_outname' type files so knowing whether this will be changed is beneficial to know.

I've included two rsl.error files. rsl_error is a normal run with use_adaptive_time_step = false and also using the 'input_outname' type file. rsl_error_adapt is the same run but with use_adaptive_time_step = true. The debug is turned up quite a bit. It seems that there is a call to 'domain_clockisstoptime' that might returning true for the adaptive time step = true case but not for when adaptive time step = false.

Thanks for taking time to review this question!


  • rsl_error.txt
    547.9 KB · Views: 73
  • rsl_error_adapt.txt
    79.9 KB · Views: 81

I'd try WRF, which is the bug fix version of WRF 3.9.

No guarantees this will fix your problem, but it is worth a try.

You might also consider trying the current version, 4.0.2.
I apologize, as I somehow have overlooked this post. I am going to attach a file. Please place it in your dyn_em/ directory and then recompile the code (no need to issue a 'clean -a' or to reconfigure). Try to run it again and let me know if that makes any difference. Thanks!


  • adapt_timestep_em.F
    18.7 KB · Views: 116