Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ARWpost error: malloc(): smallbin double linked list corrupted

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I'm facing an ARWpost error, and I didn't find a solution. Any help will be very appreciated.

ARWpost v3.1

FOUND the following input files:


Processing time --- 2018-10-08_00:00:00
Found the right date - continue
*** Error in `./ARWpost.exe': malloc(): smallbin double linked list corrupted: 0x000000000283b800 ***
======= Backtrace: =========
======= Memory map: ========
00400000-0043a000 r-xp 00000000 fd:02 565540910 /home/lammoc/wrf_operacional/operacional/ARWpost/ARWpost.exe
00639000-0063a000 rw-p 00039000 fd:02 565540910 /home/lammoc/wrf_operacional/operacional/ARWpost/ARWpost.exe
0063a000-0066c000 rw-p 00000000 00:00 0
01feb000-02e4e000 rw-p 00000000 00:00 0 [heap]
2ad9db4b5000-2ad9db4d7000 r-xp 00000000 fd:00 33554541 /usr/lib64/
2ad9db4d7000-2ad9db4da000 rw-p 00000000 00:00 0
2ad9db4f0000-2ad9db503000 rw-p 00000000 00:00 0
2ad9db6d6000-2ad9db6d7000 r--p 00021000 fd:00 33554541 /usr/lib64/
2ad9db6d7000-2ad9db6d8000 rw-p 00022000 fd:00 33554541 /usr/lib64/
2ad9db6d8000-2ad9db6d9000 rw-p 00000000 00:00 0
2ad9db6d9000-2ad9db7e1000 r-xp 00000000 fd:02 6214 /home/lammoc/instalacoes/lib/
2ad9db7e1000-2ad9db9e1000 ---p 00108000 fd:02 6214 /home/lammoc/instalacoes/lib/
2ad9db9e1000-2ad9dba2f000 r--p 00108000 fd:02 6214 /home/lammoc/instalacoes/lib/
2ad9dba2f000-2ad9dba33000 rw-p 00156000 fd:02 6214 /home/lammoc/instalacoes/lib/
2ad9dba33000-2ad9dea42000 rw-p 00000000 00:00 0
2ad9dea42000-2ad9deab1000 r-xp 00000000 fd:02 1151919 /home/lammoc/instalacoes/lib/
2ad9deab1000-2ad9decb0000 ---p 0006f000 fd:02 1151919 /home/lammoc/instalacoes/lib/
2ad9decb0000-2ad9decb1000 r--p 0006e000 fd:02 1151919 /home/lammoc/instalacoes/lib/
2ad9decb1000-2ad9decb2000 rw-p 0006f000 fd:02 1151919 /home/lammoc/instalacoes/lib/
2ad9decb2000-2ad9dedd1000 r-xp 00000000 fd:00 34342600 /usr/lib64/
2ad9dedd1000-2ad9defd1000 ---p 0011f000 fd:00 34342600 /usr/lib64/
2ad9defd1000-2ad9defd2000 r--p 0011f000 fd:00 34342600 /usr/lib64/
2ad9defd2000-2ad9defd4000 rw-p 00120000 fd:00 34342600 /usr/lib64/
2ad9defd4000-2ad9df0d5000 r-xp 00000000 fd:00 34914953 /usr/lib64/
2ad9df0d5000-2ad9df2d4000 ---p 00101000 fd:00 34914953 /usr/lib64/
2ad9df2d4000-2ad9df2d5000 r--p 00100000 fd:00 34914953 /usr/lib64/
2ad9df2d5000-2ad9df2d6000 rw-p 00101000 fd:00 34914953 /usr/lib64/
2ad9df2d6000-2ad9df2eb000 r-xp 00000000 fd:00 34342014 /usr/lib64/
2ad9df2eb000-2ad9df4ea000 ---p 00015000 fd:00 34342014 /usr/lib64/
2ad9df4ea000-2ad9df4eb000 r--p 00014000 fd:00 34342014 /usr/lib64/
2ad9df4eb000-2ad9df4ec000 rw-p 00015000 fd:00 34342014 /usr/lib64/
2ad9df4ec000-2ad9df6af000 r-xp 00000000 fd:00 33586879 /usr/lib64/
2ad9df6af000-2ad9df8ae000 ---p 001c3000 fd:00 33586879 /usr/lib64/
2ad9df8ae000-2ad9df8b2000 r--p 001c2000 fd:00 33586879 /usr/lib64/
2ad9df8b2000-2ad9df8b4000 rw-p 001c6000 fd:00 33586879 /usr/lib64/
2ad9df8b4000-2ad9df8b9000 rw-p 00000000 00:00 0
2ad9df8b9000-2ad9df8c3000 r-xp 00000000 fd:02 185098 /home/lammoc/instalacoes/lib/
2ad9df8c3000-2ad9dfac3000 ---p 0000a000 fd:02 185098 /home/lammoc/instalacoes/lib/
2ad9dfac3000-2ad9dfac4000 r--p 0000a000 fd:02 185098 /home/lammoc/instalacoes/lib/
2ad9dfac4000-2ad9dfac5000 rw-p 0000b000 fd:02 185098 /home/lammoc/instalacoes/lib/
2ad9dfac5000-2ad9dfacd000 rw-p 00000000 00:00 0
2ad9dfacd000-2ad9dfaee000 r-xp 00000000 fd:00 34342006 /usr/lib64/
2ad9dfaee000-2ad9dfcee000 ---p 00021000 fd:00 34342006 /usr/lib64/
2ad9dfcee000-2ad9dfcef000 r--p 00021000 fd:00 34342006 /usr/lib64/
2ad9dfcef000-2ad9dfcf0000 rw-p 00022000 fd:00 34342006 /usr/lib64/
2ad9dfcf0000-2ad9dfd01000 rw-p 00000000 00:00 0
2ad9dfd01000-2ad9e00ea000 r-xp 00000000 fd:00 33968768 /usr/lib64/
2ad9e00ea000-2ad9e02ea000 ---p 003e9000 fd:00 33968768 /usr/lib64/
2ad9e02ea000-2ad9e02ef000 r--p 003e9000 fd:00 33968768 /usr/lib64/
2ad9e02ef000-2ad9e02f6000 rw-p 003ee000 fd:00 33968768 /usr/lib64/
2ad9e02f6000-2ad9e02f8000 rw-p 00000000 00:00 0
2ad9e02f8000-2ad9e02fa000 r-xp 00000000 fd:00 34914951 /usr/lib64/
2ad9e02fa000-2ad9e04fa000 ---p 00002000 fd:00 34914951 /usr/lib64/
2ad9e04fa000-2ad9e04fb000 r--p 00002000 fd:00 34914951 /usr/lib64/
2ad9e04fb000-2ad9e04fc000 rw-p 00003000 fd:00 34914951 /usr/lib64/
2ad9e04fc000-2ad9e0515000 r-xp 00000000 fd:02 101 /home/lammoc/instalacoes/lib/
2ad9e0515000-2ad9e0715000 ---p 00019000 fd:02 101 /home/lammoc/instalacoes/lib/
2ad9e0715000-2ad9e0716000 r--p 00019000 fd:02 101 /home/lammoc/instalacoes/lib/
2ad9e0716000-2ad9e0717000 rw-p 0001a000 fd:02 101 /home/lammoc/instalacoes/lib/
2ad9e0717000-2ad9e077c000 r-xp 00000000 fd:00 34494793 /usr/lib64/
2ad9e077c000-2ad9e097c000 ---p 00065000 fd:00 34494793 /usr/lib64/
2ad9e097c000-2ad9e097e000 r--p 00065000 fd:00 34494793 /usr/lib64/
2ad9e097e000-2ad9e097f000 rw-p 00067000 fd:00 34494793 /usr/lib64/
2ad9e097f000-2ad9e0980000 rw-p 00000000 00:00 0
2ad9e0980000-2ad9e0ae5000 r-xp 00000000 fd:00 34767607 /usr/lib64/
2ad9e0ae5000-2ad9e0ce4000 ---p 00165000 fd:00 34767607 /usr/lib64/
2ad9e0ce4000-2ad9e0d33000 r--p 00164000 fd:00 34767607 /usr/lib64/
2ad9e0d33000-2ad9e0d38000 rw-p 001b3000 fd:00 34767607 /usr/lib64/
2ad9e0d38000-2ad9e3d71000 rw-p 00000000 00:00 0
2ad9e3d71000-2ad9e3dac000 r-xp 00000000 fd:00 34342040 /usr/lib64/
2ad9e3dac000-2ad9e3fab000 ---p 0003b000 fd:00 34342040 /usr/lib64/
2ad9e3fab000-2ad9e3fac000 r--p 0003a000 fd:00 34342040 /usr/lib64/
2ad9e3fac000-2ad9e3fad000 rw-p 0003b000 fd:00 34342040 /usr/lib64/
2ad9e3fad000-2ad9e3fdf000 r-xp 00000000 fd:00 33587512 /usr/lib64/
2ad9e3fdf000-2ad9e41de000 ---p 00032000 fd:00 33587512 /usr/lib64/
2ad9e41de000-2ad9e41df000 r--p 00031000 fd:00 33587512 /usr/lib64/
2ad9e41df000-2ad9e41e0000 rw-p 00032000 fd:00 33587512 /usr/lib64/
2ad9e41e0000-2ad9e4208000 r-xp 00000000 fd:00 34307280 /usr/lib64/
2ad9e4208000-2ad9e4408000 ---p 00028000 fd:00 34307280 /usr/lib64/
2ad9e4408000-2ad9e4409000 r--p 00028000 fd:00 34307280 /usr/lib64/
2ad9e4409000-2ad9e440a000 rw-p 00029000 fd:00 34307280 /usr/lib64/
2ad9e440a000-2ad9e4457000 r-xp 00000000 fd:00 34342637 /usr/lib64/
2ad9e4457000-2ad9e4656000 ---p 0004d000 fd:00 34342637 /usr/lib64/
2ad9e4656000-2ad9e465a000 r--p 0004c000 fd:00 34342637 /usr/lib64/
2ad9e465a000-2ad9e465b000 rw-p 00050000 fd:00 34342637 /usr/lib64/
2ad9e465b000-2ad9e465c000 rw-p 00000000 00:00 0
2ad9e465c000-2ad9e4680000 r-xp 00000000 fd:00 34342636 /usr/lib64/
2ad9e4680000-2ad9e487f000 ---p 00024000 fd:00 34342636 /usr/lib64/
2ad9e487f000-2ad9e4882000 r--p 00023000 fd:00 34342636 /usr/lib64/
2ad9e4882000-2ad9e4883000 rw-p 00026000 fd:00 34342636 /usr/lib64/
2ad9e4883000-2ad9e49a7000 r-xp 00000000 fd:00 34342635 /usr/lib64/
2ad9e49a7000-2ad9e4ba7000 ---p 00124000 fd:00 34342635 /usr/lib64/
2ad9e4ba7000-2ad9e4bac000 r--p 00124000 fd:00 34342635 /usr/lib64/
2ad9e4bac000-2ad9e4bae000 rw-p 00129000 fd:00 34342635 /usr/lib64/
2ad9e4bae000-2ad9e4bb0000 rw-p 00000000 00:00 0
2ad9e4bb0000-2ad9e4bd8000 r-xp 00000000 fd:00 34342019 /usr/lib64/
2ad9e4bd8000-2ad9e4dd7000 ---p 00028000 fd:00 34342019 /usr/lib64/
2ad9e4dd7000-2ad9e4dde000 r--p 00027000 fd:00 34342019 /usr/lib64/
2ad9e4dde000-2ad9e4ddf000 rw-p 0002e000 fd:00 34342019 /usr/lib64/
2ad9e4ddf000-2ad9e4de2000 r-xp 00000000 fd:00 34342024 /usr/lib64/
2ad9e4de2000-2ad9e4fe1000 ---p 00003000 fd:00 34342024 /usr/lib64/
2ad9e4fe1000-2ad9e4fe2000 r--p 00002000 fd:00 34342024 /usr/lib64/libplds4.soAbortado (imagem do núcleo gravada)

About my system:

[lammoc@localhost ARWpost]$ gfortran -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl= --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --disable-libgcj --with-isl=/builddir/build/BUILD/gcc-4.8.5-20150702/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.5-20150702/obj-x86_64-redhat-linux/cloog-install --enable-gnu-indirect-function --with-tune=generic --with-arch_32=x86-64 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.8.5 20150623 (Red Hat 4.8.5-28) (GCC)
I found this topic on another forum ( ) with similar problem.

If I set: plot='list' on the namelist.ARWpost, then ARWpost.exe works, but the ctl doesn't have rainc, rainnc and t2.
fields = 'height,geopt,theta,tc,tk,td,td2,rh,rh2,umet,vmet,pressure,u10m,v10m,wdir,wspd,wd10,ws10,slp,mcape,mcin,lcl,lfc,cape,cin,dbz,max_dbz,clfr'

If I set: plot='all' then the ARWpost.exe error happens.

I'm facing this problem onto 2 different computers. The solution pointed on the other forum was change some F90 files, but I think that should be another way to solve this.
I am not able to reproduce the error you are seeing with the same version of ARWpost. I do not have access to a GNU V4.8.5 compiler, however. The version I am testing with is GNU V7.2.0). I have a couple of tests for you to try.
1) Can you try to update your GNU to a newer version, since this is free software, then run again and see if that makes any difference.
2) I'm going to attach a pretty basic wrfout* file. Can you try to use this one to see if you get the same problem. If not, then we will know it's related to your specific wrf output file(s). To attach to this forum, I had to tar/zip the file, so you'll need to unpack it first before running.

To address the problem you mentioned with not being able to get the variables RAINC,RAINNC, T2 when using the 'list' option, did you specifically list those variable names in the fields category when you ran with that option? If so, they theoretically should be in the .ctl output. I just tested this, as well, and it works.


  • wrfout.tar.gz
    8.1 MB · Views: 68
Hi ! Thanks for your answer!

First I tried the option #2:
- Downloaded your file and unpacked;
- Properly set namelist.ARWpost to match the dates;
- Tests with your file:
--- Configuration #1:
(It worked. ARWpost created the .ctl and .dat files)
--- Configuration #2:
plot = 'list'
fields = 'RAINC,RAINNC,T2,height,geopt,theta,tc,tk,td,td2,rh,rh2,umet,vmet,pressure,u10m,v10m,wdir,wspd,wd10,ws10,slp,mcape,mcin,lcl,lfc,cape,cin,dbz,max_dbz,clfr'
(It worked. ARWpost created ctl and dat files with only those variables listed above).
--- Configuration #3:
plot = 'all_list'
(It worked too. Every WRF variable were available)

Then I uploaded to that machine a wrfout file that was created today on a third machine with our operational WRF system (version 3.4.1) that works fine. When I tried to create the .ctl file, the same problem happened.

I'm going to attach here a short test run that I'm not able to transform into ctl and dat files. I know you are busy, but I'll appreciate if you have some time to give a look on it. Is that file ok?


  • wrfout.tar.gz
    13.2 MB · Views: 70
I believe the problem is that your ARWpost may have been compiled with an older version of netCDF that does not support V4 compressed files. I built ARWpost using an older version of netCDF (V3.6.3) and I get the same problem with your file. As a side note, I am also not able to use the 'ncdump' command with your file - I get an 'Unknown file format' error. However, when I built with a newer version of netCDF (V4.6.1), I am able to run ARWpost with your file. Can you check on the version of netCDF that was used to build ARWpost, or simply try to compile it again with an updated version and see if that makes a difference?