Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ARWpost Problems

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Din19

Member
Hi!

I am a new user of WRF. I am trying to convert the wrf output file to csv file. As well as I understood, first, I should run ARWpost to get .ctl file, which further should be converted to .nc file. After that, .nc file can be further converted to .csv file using Python.

However, when I run ARWpost, only one of the wrf output files is processed, others are not found.

It looks as follows:
START PROCESSING DATA

Processing time --- 2018-06-01_00:00:00
Found the right date - continue

Processing time --- 2018-06-01_01:00:00
Date not in this file - see if there are more files
Found the right date - continue

..................................................
Processing time --- 2018-06-02_00:00:00
Date not in this file - see if there are more files
Found the right date - continue

DONE Processing Data

CREATING .ctl file

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! Successful completion of ARWpost !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


I tried to follow recommendations mentioned in the forum https://forum.wrfforum.com/viewtopic.php?f=30&t=10818#. I made changes in two sources code files "input_module.f90" and "module_date_pack.f90".However, it did not help.

Could please anyone help me to resolve this problem?

Thank you very much!
 
Hi,
Can you attach your namelist.ARWpost file so I can take a look? Can you also issue the following?

ls -ls path-to-wrfout-files/wrfout* >& wrfout.txt

and send that wrfout.txt file, as well? Thanks!
 
Thank you very much for your reply.

The attached files contain input.ARWpost file and wrfout.txt file.

Thank you!
 

Attachments

  • wrfout.txt
    6 KB · Views: 33
  • namelist.ARWpost
    1.2 KB · Views: 50
In the original message, it looks like ARWpost processed time 2018-06-01, but then wasn't able to process 2018-06-02; however, the namelist you sent me shows you are trying to process 2018-06-02 to 2018-06-04. Do you have a new output log for trying to run ARWpost for this namelist? If so, can you send me the full log? Thanks!
 
Thank you very much for your reply. I have run ARWpost many times, probably I could confuse the files.
I have added the line "adjust_output_times = .true." to the &time_control section of the namelist.input file and run WRF simulations again. After that, I run ARWpost again, but I got the same error.
I attach the namelist.ARWpost, wrfout.txt and the screenshot of the recent ARWpost simulation. I have tried different solutions suggested in forums, but they did not help (((
Actually, I am trying to process wrf output files for the third domain, and the program can't recognize the files. Seems like ARWpost was compiled correctly.

ARWpost run.pngView attachment namelist.ARWpostView attachment wrfout.txt
 
I would like to say that I installed ARWpost v 3.1.several times( uninstalled and installed again). First time I installed WRF and ARWpost using GNU compilers. Then I reinstalled Ubuntu and installed WRF and ARWpost using Intel compilers. However, the problem remained the same. The program is compiled using the latest version of netCDF (netcdf-fortran-4.5.3. and netcdf-c-4.7.4).

I have tried several suggestions mentioned in the following forums https://forum.wrfforum.com/viewtopic.php?f=41&t=5996 ,https://forum.wrfforum.com/viewtopic.php?f=30&t=10818 . But it did not help(((
I set "adjust_output_times = .true. to the namelist.input, but it also did not help (((. I also tried to install ARWpost v 2.2, but I failed to compile it.

It is highly important for me to get the output from ARWpost, because further, I need to convert it to csv using Python code.

I am sorry for disturbing you, but I cannot find more information on how to resolve such kinds of problems in ARWpost. Could you please help me to resolve this issue?
Thank you very much!
 
I would highly appreciate it if someone could help me. I have been trying to resolve this issue for the last 4 weeks, applying various solutions from various forums, and still, there are no successful results.
 
Hi,
I apologize for the long delay in response. Unfortunately our resources are quite limited at the moment. We are trying our best to get to messages in a timely manner. Thank you for your patience.

In your wrfout.txt file, I see that the initial wrfout_d03 file (2018-06-02_12:00:00) is much smaller than the other files. This makes me curious whether that file was written correctly. Can you try running arwpost for just a single time, starting at a time from hour 13 or later to see if it runs? If so, then it's likely an issue with that hour 12 file.

If that doesn't seem to be the issue, will you please upload a couple of your wrfout_d03* files so I can test this out with your data? The files will likely be too large to attach. Take a look at the home page of this forum for information on sending large files. Thanks!
 
Hello!

Thank you for your response. I have tried to run simulations for June 2, 13:00 till June 2 15:00, but I got the same error. For single hour it also did not work.

The wrfout files for the third domain I have attached in zip format to this post.

View attachment WRFOUT D03.zip

I have tried to upload it to the cloud, but seems like it did not work properly.
https://nextcloud.mmm.ucar.edu/nextcloud/index.php/s/DkPamzUKYhQkWEI

I also attach namelist.input and rsl.out files

View attachment rsl.out.rar
View attachment namelist.input

Thank you very much!

I am looking forward to hearing from you
 
Hi !

What could be the possible reason of my problem ?

I would appreciate it if you could help me, because I cannot find solution.
 
I would like to highlight, that when I tried to run ARWpost for the files obtained from WRF Online Tutorial, I got the same error.Is the problem in the installed version of ARWpost?
 
Are there any other ways to convert wrfout files to csv format? I would highly appreciate it if you could help me
 
Indira said:
I would like to highlight, that when I tried to run ARWpost for the files obtained from WRF Online Tutorial, I got the same error. Is the problem in the installed version of ARWpost?

Hi ! I have tried to run the workout files from WRF online Tutorial in ARWpost installed with gnu compiler. It seems like ARWpost is properly compiled with gnu compiler. I checked a configure.arwp file, and it is okay.

Capture.PNG

-L$(NETCDF)/lib -I$(NETCDF)/include -lnetcdff -lnetcdf is also written in the Makefile.

I have added the time requirements from https://forum.wrfforum.com/viewtopic.php?f=30&t=10818.

But the error is the same.

I don't think that the files from WRF online Tutorial may have any issues.


It means that I need to add something in one of the ARWpost files (src folder), so that it could recognize the files.

Looks like NetCDF is installed properly, and the directory to NetCDF folder is indicated.

I did not find any suggestions about what else could be added to the ARWpost files (src)

Could you please help me to find the core of the problem?
 
Hi,
I do not see an error in your output. It originally says it can't find the right date, but then says it found it. I'm not sure why it says that initially. It looks like you're asking for your output to be "/home/indira4/WRF/ARWpost/test." If you look in the directory "/home/indira4/WRF/ARWpost/," do you see any files named "test.ctl" and "test.dat?"
 
Indira said:
Yes, I get test.ctl, and test.dat

View attachment test.zip

This is my test.ctl file

What I noticed, there is no " DSET ^.test_yyyy-mm-dd_00:00.grd" in the first line. Later, when I convert it to nc and use in Python, it does not find dates. Look like it creates .ctl file for one file o nly
 
Hi,
Okay, I do see what you're saying. I think it's actually creating the file for all the times, but that first line is not showing the dates, as you said. I saw the same in the test I did, and when I actually plot the files with grads, I'm seeing all the different times I requested. I'm not sure why it's not displaying the date at the top. This is something we will have to look into. In the meantime, the .ctl file can be easily modified, and you could add the date information you need, if that helps.
 
Top