Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

CFL error when running wrf.exe

sluque

New member
Hi there. I am trying to run WRF with three nested domains of 15km, 3km and 1km horizontal resolutions.

I attach my namelist.input.

I keep getting cfl errors no matter what I do. I tried reducing the time step but i even changed it to 1s for the second domain (which is the one having problems) and didnt work.

I used w_damping = 0 and w_damping = 1 and changed the epssm value to 0.9. Nothing worked.

I also attach one of the error logs.

What I am missing here? What else could I try?

Thank you very much
Sol
 

Attachments

  • rsl.error.0000
    15.1 KB · Views: 1
  • namelist.input
    5.9 KB · Views: 4
Sorry, the log file attached didnt contain the cfl error. I attach one that does.
 

Attachments

  • rsl.error.0000
    9.6 KB · Views: 2
Hi,
There are a few namelist settings I'd recommend playing around with to see if you can get past this. These are some of your current settings.

Code:
&domains

e_we                                = 111, 121, 133,
e_sn                                = 101, 101, 127,
e_vert                              = 80, 80, 80
p_top_requested                     = 1000,
dx                                  = 15000, 3000,  1000.0,
dy                                  = 15000, 3000,  1000.0,
parent_grid_ratio                   = 1,     5,     3,
parent_time_step_ratio              = 1,     5,     3,

1) Given the fairly small size of your domains (e.g., 111x101), I believe 80 vertical levels is probably too many. This would probably work better with something closer to the default value of e_vert, which is 45.

2) You may want to try using the same parent_grid_ratio and parent_time_step_ratio for all of your domains. So setting those to = 1, 3, 3 or = 1, 5, 5 would probably work better. Of course you would need to rerun geogrid and metgrid to do this.
 
Can you attach your modified namelist.input file, and package all of your rsl files together into a single *.tar file and share that, as well? Thanks!
 
Yes, of course. I changed e_vert to 45 as suggested and parent_time_step_ratios to 1, 5, 5.

I didnt change parent_grid_ratio because I cant change my domain sizes (I need to compare this simulations to others previously done).

The cfl errors appear in rsl.error.0004/0006/0007/0008/0014/0016/0017/0018.

Thank you very much
 

Attachments

  • cfl_error.tar.gz
    57.6 KB · Views: 1
Hi,
Thanks for sending those. Can you also attach your namelist.wps file? I'd like to try to run a test using your specific domain to see if I can reproduce the issue. Just to be sure - you're using un-modified "out-of-the-box" WRF code, correct?
 
Hi there. Thank you very much.

Of course, here I attach my namelist.wps.

I am using an un-modified WRF code, v4.5
 

Attachments

  • namelist.wps
    889 bytes · Views: 1
Hello there.

Just wanted to let you know, and everyone else experiencing similar problems, that the issue was solved by changing the number of processors.

I followed these instructions:



Im not sure how this is related to the cfl errors, but it worked.

Thank you very much
 
Top