Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

CFL errors

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am running WRF at 20km currently and discovered CFL errors the time step before the model crashes. The easy solution would be to just reduce the time step until it stops crashing, but this seems like not the best method. What do you recommend for figuring out the proper time step? These runs are being used in climate CPM runs and I was advised against using the adaptive time step option.



Try "w_damping=1".

The general rule has always been the timestep can be at most your grid spacing x 6.
Thanks for your response Kevin. I'll try the w_damping. I was already using 4xdx due to test runs saying that 6xdx encountered many problems with CFL errors.

time_step = 4 x grid interval is a conservative option. You can always try this. I won't suggest to further reduce the time step for climate simulation.
As Kevin suggested, w_damping is a good option to suppress CFL violation.
if your domain is over complex terrain area with large topography gradient, then increasing the value of epssm is also helpful.