Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

CFL errors

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

neel14

Member
I have 4 domains with the innermost domain @1km grid size. I am getting segmentation faults due to cfl errors only in d04 even after reducing time step to 1s in d04. I have followed everything recommended here https://forum.mmm.ucar.edu/phpBB3/viewtopic.php?f=73&t=133 I am confused how to solve this. Is there any other alternative to solve this? Have attached the namelist. Please help.
 

Attachments

  • namelist.input
    7.2 KB · Views: 133
Please turn off nudging and rerun the case. Let's see whether the case can work.
Note that spectral nudging suppresses internal model variability at smaller scale. This option is recommended for long term and coarse resolution run.
 
Hi,I have tried with turning off nudging but still getting errors. Do I need to reduce d01 size? I read somewhere timestep being related to mapfactor.

Regarding spectral nudging, I have kept the wavenumbers as 1 for the inner 3 domains. Does not that mean nudging will not be used for d02, d03 and d04 even if it is turned on? I always had this question in mind.
 
(1) If you turn on spectral nudging for D02-D04 (specified by grid_fdda), then nudging will be conducted over these domains.
(2) Your namelist.input looks fine.
(3) CFL violation indicates the model integration becomes unstable. In addition to time step, some other factors like very steep topography gradient can also cause the problem.
(4) map factors should be around 1.

I wonder where your domains are located? Did the case crash immediately or after running for a while? In addition to CFL violation,did you find other error messages?
 
I have attached the domains image.(wps_show_dom.png)

1.Crash happened sometime after starting, not immediately. There were SIGINT errors but those are caused by the cfl errors I guess.
2.My domains especially d03 and d04 do contain steep terrain.
3.Map factor is 1.32

I have completed simulations successfully with the given namelist upto d03. When I added d04, these errors started appearing.
 

Attachments

  • wps_show_dom.png
    wps_show_dom.png
    173.1 KB · Views: 1,937
I believe this is a problem related to large topography gradient. We did see similar issues before.
Please increase epssm to 0.9 and see whether this case works. If it still doesn't work, then I have to say that the domain D04 needs to be relocated. The model has its limitation and it cannot handle some extreme conditions like the one shown in your case.
 
Errors are not occuring now at that time where it occured before, but the integration time has substantially increased.
Thanks a lot for your advice.
Also is 0.9 the upper limit for epssm?
 
Top