Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Compile WRF on Virtual box + MACOS

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I have an issue which doesn't seem to be discussed yet.
Basically, I am trying to compile WRF on Virtual box installed on MacOS but it does not want to build it. I have read on another blog that there are some issues running WRF on virtual box on MacOS but I am wondering if someone has a solution before I do everything again on a windows computer...
This is my setup.
- I am using tcsh
- I followed the compilation page
- All the TESTS where run successfully
- All the .tar file where installed successfully
- I checked again using: which gcc --version and which gfortran --version
- .tar file where added to path
- the complete path before ./configure is:
setenv DIR /home/usr/Build_WRF/LIBRARIES
setenv CC gcc
setenv CXX g++
setenv FC gfortran
setenv FCFLAGS -m64
setenv F77 gfortran
setenv FFLAGS -m64
setenv JASPERLIB $DIR/grib2/lib
setenv JASPERINC $DIR/grib2/include
setenv LDFLAGS -L$DIR/grib2/lib
setenv CPPFLAGS -I$DIR/grib2/include
setenv PATH $DIR/mpich/bin:$PATH
setenv PATH $DIR/netcdf/bin:$PATH
setenv NETCDF $DIR/netcdf
setenv WRF_EM_CORE 1

- I configured to nb 32 and then 1, all runs smoothly
- UNTIL HERE where I want to ./compile em_real > & log.compile
- It runs for 5 minutes and then nothing, so I go in the log.compile file and get fatal errors for gfortran
- Tried to.
./clean -a
./compile em_real >& log.compile

- It's now the 5th if not more time I try and still nada.
I've attached the log.compile for someone to enlight me on this :)
Many thanks


  • log.compile
    984.6 KB · Views: 9
We've seen this same error when trying to compile on a cloud-computing platform when the instance wasn't configured to be large enough, or with enough memory. I have a feeling you're dealing with a similar issue in your virtual box space. Are you able to make it any larger to test this out?
I wanted to reach out again to suggest another option before trying to access a larger size. Take a look at this modification to our code that will be released in a few weeks. The issue was specific to AWS builds of the model, but also related to other systems, and may include yours. However, the issue seemed to have been specifically related to using an Intel compiler, and since you're using GNU, this may not be the same issue. Let me know whether that modification helps you, and if not, then see my previous post. Thanks!