Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Compiling WRF with no leap years support

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I have been trying to compile WRF with no-leap years support without success.

I have edited the configure.wrf file adding -DNO_LEAP_CALENDAR to the macro ARCH_LOCAL before compiling WRF. So I compiled WRF, but when I run real.exe it crashes.
Here is the error message:

-------------- FATAL CALLED ---------------
Error:: ESMF_Initialize not called

I'm using CESM data which have no leap years. How can I fix this?

Thank you.


View attachment configure.wrf
View attachment compile.log
Can you issue the following from your WRFV3/ directory:
1) ./clean -a
2) ./configure
(at this point, add the -DNO_LEAP_CALENDAR setting and save the file)
3) recompile the code

Then try running real again. If you get the same error, please attach your new configure.wrf file, compile log, your namelist.input file, and your running log/error files (e.g., rsl.error.0000).