Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Correct geog_data_res entry for lake+modified land cover

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

I have a modified static data that looks like the attached file (modified_lc.png)
To generate this plot, I set the following:

 parent_id         =   1,       1,      2,
 parent_grid_ratio =   1,       5,      5,
 i_parent_start    =   1,       10,     32,
 j_parent_start    =   1,       9,      39,
 e_we              =  41,      101,     141,
 e_sn              =  41,       101,    111,
 geog_data_res     = 'usgs_5m+default','usgs_30s+default','usgs_30s+default',
 dx = 25000,
 dy = 25000,
 map_proj = 'mercator',
 ref_lat   =  15.0,
 ref_lon   = 121.5,
 truelat1  =  15.0,
 truelat2  =  15.0,
 stand_lon = 119.5,
 geog_data_path = 'geog',

I replaced the 36001-37200.12001-13200 file in the geog/landuse_30s directory with a

My domain has an inland lake as shown in the other attached figure (with_lake.png)
Do generate this plot, I tried the following:

 geog_data_res     = 'usgs_5m+default','usgs_30s+default','usgs_lakes+usgs_30s+default',

Unfortunately, the geogrid cannot recognize the updated land cover if the "usgs_lakes" is activated.

I also tried:

geog_data_res     = 'usgs_5m+default','usgs_30s+default','usgs_lakes+30s',

But this is not working too.

Am I missing a step here?

What should be the correct entry on the geog_data_res so that I can have both lakes and modified landuse/landcover at the same time?

I also tried modifying the 36001-37200.12001-13200 in the geog/landuse_30s_with_lakes/. This time, the lake disappeared....

I'll appreciate any help on this.



  • modified_lc.png
    92.6 KB · Views: 1,345
  • with_lake.png
    94.1 KB · Views: 1,345
  • namelist.wps
    874 bytes · Views: 51
(1) The static dataset "landuse_30s" doesn't specify any type for lake. This is why WPS cannot recognize the data you modified.
Please modify the dataset "landuse_30s_with_lakes", and specify the lake type to be 28.

(2) Then in your namelist.wps, please set
geog_data_res = 'usgs_lakes+default','usgs_lakes+default','usgs_lakes+default',

Let me know if you still have problems.
Hi Ming-Chen,

You are right!
Thank you for this.

For (2), I used the following:
geog_data_res = 'usgs_lakes+usgs_10m','usgs_lakes+usgs_30s','usgs_lakes+usgs_30s',

Is this also okay? I modified both landuse_30s and landuse_30s_with_lakes.

The landuse/land cover plot looks the same if I used your suggested one.

I am really sorry to get back so late, ---somehow this question was skipped.
I just want to confirm that everything works as expected.
@Ming Chen,

Thank you for the follow up response.

I solved this issue but I'm I would like to consult on the results.

When I initialized the inland lake with tavgsfc option in WPS (defaultLC_lake; usgs+lake), I get weird results relative to the observation (AWS_Tem, AWS_rh in the figure).

Default USGS and MODIS behaves almost similarly and both are better than runs with lake initialization.

Is this a common problem with the tavgsfc option?


  • Screen Shot 2021-06-23 at 12.55.59 PM.png
    Screen Shot 2021-06-23 at 12.55.59 PM.png
    135.7 KB · Views: 1,233
Hi, Lyndz
TAVGSFC is expected to give us a more realistic skintemp over inland water body. In your case, this seems not correct. Can you compare your wrfinput file that includes inland lake as a landuse type with the wrfinpiut without inland lake? Is there way you can know which is more realistic?