Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Different time interval for wrfout creation gives different result

janac4

Member
Hello,
I have been doing some tests to compare the output when setting 1 hour interval between wrfout files and 10 minute interval.
When comparing instantaneous variables at the same time, the result is almost the same at the begging of the simulation, but after a period they seem to diverge partially.
The model is using the same configuration of adaptive time step, why is the output different?
Thank you in advance
 
Hi,
What variables are you comparing?
Can you attach your namelist.input file and let me know which version of WRF you are using? Thanks!
 
Hi,
What variables are you comparing?
Can you attach your namelist.input file and let me know which version of WRF you are using? Thanks!
Hi, I'm working with WRF 4.4.1 and the attached namelist. I am just starting to use lightning option and wanted to have more frecuent output since LPI variable (ligtning potential index) is instantaneous. When checking this index and rain variables, I saw some differences between files from different history_interval_m simulations.
 

Attachments

  • namelist.input
    6.2 KB · Views: 3
Hi,
I believe this is happening because of the namelist setting "step_to_output_time = .true." Because you are outputting at different intervals, the values differ when the time_step is slightly different because it's trying to make sure to output at the right time_step. I ran a test and verified what you're seeing. Then I set "step_to_output_time = .false." and ran another test. That time there were no differences in output values. Unfortunately there isn't a way around this, so you'll have to decide whether you'd rather have identical output values, or whether you would rather have the output at the intervals you request.
 
Hi,
I believe this is happening because of the namelist setting "step_to_output_time = .true." Because you are outputting at different intervals, the values differ when the time_step is slightly different because it's trying to make sure to output at the right time_step. I ran a test and verified what you're seeing. Then I set "step_to_output_time = .false." and ran another test. That time there were no differences in output values. Unfortunately there isn't a way around this, so you'll have to decide whether you'd rather have identical output values, or whether you would rather have the output at the intervals you request.
Thank you so much for your answer, it all make sense now.
 
Top