Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Downloaded GFS data unable to get executaed by ungrib.exe

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Dear all,

I have been experiencing this problem for a while. I have downloaded the GFS data from for 24 hours starting from gfs.t00z.pgrb2.0p50.f000 to gfs.t00z.pgrb2.0p50.f024 . But when I am executing it using ungrib.exe it shows

Looking for data at time 2021-03-26_00
Found file: FILE:2021-03-26_00
Looking for data at time 2021-03-26_03
Found file: FILE:2021-03-26_03
Looking for data at time 2021-03-26_06
Found file: FILE:2021-03-26_06
Looking for data at time 2021-03-26_09
ERROR: Data not found: 2021-03-26_09:00:00.0000

I have tried it running it for 12 hours too. But the same error is coming every time. I am attaching namelist.wps and namelist.input. I'll be highly obliged of getting help from your end.


  • namelist.wps
    764 bytes · Views: 58
  • namelist.input
    3.9 KB · Views: 49
This is because you don't have the GFS data at 2021-03-26_09:00:00.00

Please take a look at your GRIB file, and make sure the GFS file at the above time does exist in your working directory.