Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ERA5 Wildly Under Producing Precipitation


New member
Hello there! I'm working on a model over the Gulf of Mexico with ERA5 data I downloaded from the Copernicus Data Store.
The model runs just fine, but it's producing less than 10mm of rainfall when there should be upwards of 80mm. I think there is a problem with how I am processing the ERA5 data in the WPS portion, but I'm not 100% certain what's wrong. I tried mucking about with the different parameterization schemes, but nothing I do changes the quantity of precipitation so I don't really think that's the issue.

The basic steps I go through for the ERA5 data:
1. I ungrib the surface and pressure level data, then do the same for the Invariant file
2. I run metgrid
3. I run real and wrf

Here is a link to the invariant file information because I thought that I might be doing something incorrectly with it:

Here is a link to my ERA5 data:

I have tried running this same test simulation with GFS and NARR data and both are producing rainfall at about 80mm so I was hoping that someone out there has had experience with ERA5 under-performing. Thank you for any advice you can offer.


  • namelist.input
    6.1 KB · Views: 4
  • namelist.wps
    1.8 KB · Views: 3
Your namelist.input looks fine. I agree that this issue may possibly be related to the input data. Can you try to download ERA5 from NCAR RDA:

then try again?

I am not sure whether the data from the link you posted are correct or not. But I know that the ERA5 data from CISL RDA are correct.
Sorry for the slow response, I've been trying to do what you suggested, but have been running into more troubles!

I finally got all the pressure level, surface, and invariant data downloaded from the link you provided. Running ungrib for the Invariant files and surface data worked fine, but I can't get the pressure level data to ungrib properly. It generates the PFILE for the time period I'm running it for and then stops saying "ERROR: unkown out_format, ifv = 1132574698". I've been having a fruitless effort finding any information on what it means. I've tried it multiple times and even tried re-downloading the pressure level data.

Another strange part about this is the fact that ungrib for this data still works in the terminal. From the working directory if I just use ./ungrib.exe, it works (for the 2 or so days I can get before I hit the wall time), but if I submit it as a batch job it fails. I'd really rather not have to ungrib day by day in the terminal, if possible, so do you have any information on this error?


  • ungrib.log.txt
    7.2 MB · Views: 1

I have a question regarding the ERA-5 data. Following this post, I included the 'ERA5_INVARIANT' option in the namelist.wps and kept the ERA5_INVARIANT.txt in the WPS directory.

But do I also need to download any ERA-5 invariant data and ungrib it? This link provides an ERA5 atmospheric invariant fields [GRIB1] option, but the data is available only for this date: 1979-01-01.

Can someone please clarify whether I need ERA-5 invariant data or not? If yes, where do I get the data?




  • era5_invariant.PNG
    125.9 KB · Views: 6
The ERA5 invariant data that can be downloaded from NCAR RDA Dataset ds633.0 is the data you need. It provides information of lands mask, terrain height etc. and these variables won't change with time. Therefore, the data of 1979 can be used for your case in other time, e.g., 2003.
Please download this data, then follow the instruction in the post How to Process ERA5 Data to process this data and other ERA5 data.