Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error: Cannot use moist theta option with old data

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Dear all,

I am doing sensitivity tests using one-way nesting on WRF V4 with a July 31, 2015 event. The wrf.exe runs smoothly before the ndown process. However, when I ran wrf.exe using wrfinput_d01 and wrfbdy_d01 (from ndown) it shows the following error. The input data I used is GFS. I already tried running this before with a May 2017 event and it worked fine. However, I checked the number of metgrid levels and they differ. The 2015 GFS data only gave me 27 vertical levels while the 2017 data has 32. I am not sure if this is causing the problem or the data I'm using is outdated. I have attached the error files.

taskid: 0 hostname: Hangin
Quilting with 1 groups of 0 I/O tasks.
Ntasks in X 2 , ntasks in Y 2
Parent domain
ids,ide,jds,jde 1 154 1 154
ims,ime,jms,jme -4 84 -4 84
ips,ipe,jps,jpe 1 77 1 77
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1 , 148365608 bytes allocated
med_initialdata_input: calling input_input
Input data is acceptable to use: wrfinput_d01
Timing for processing wrfinput file (stream 0) for domain 1: 0.15309 elapsed seconds
Max map factor in domain 1 = 0.87. Scale the dt in the model accordingly.
---- WARNING : Older v3 input data detected
-------------- FATAL CALLED ---------------
---- Error : Cannot use moist theta option with old data
Thank you,


    15.3 KB · Views: 44
Hi Cathrene,
I'm actually working with another user who is experiencing this same problem with V4.0. I haven't yet been able to track down the root cause. When I run a basic ndown case, I don't get the error. Perhaps I can find some similarities in your two cases that may lead me to the cause? Can you please tell me the steps you are taking to get to the error, and can you also send the additional namelists you used for this (namelist for real.exe, wrf d01 run, ndown.exe)? Thanks!

And just to verify, the met_em* files all come from WPSV4.0, correct?