Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ERROR: Error in ext_pkg_write_commit

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

I am running WRF V4.0 with ec-earth data for one year (January1st to December 31st), with three nested domains with resolution 45x15x5 km, and dimensions:
e_we = 81, 103, 181,
e_sn = 81, 103, 157,
When i run metgrid.exe, it crashes always at the same date, while processing d03 (3rd November at 18h) with the error:
WRF_DEBUG: NetCDF error: NetCDF: HDF error
WRF_DEBUG: NetCDF error in ext_ncd_open_for_write_commit wrf_io.F90, line
ERROR: Error in ext_pkg_write_commit
application called MPI_Abort(MPI_COMM_WORLD, 51879152) - process 0
I also tried to run metgrid.exe in two periods (jan-jun and jun-dec), and in this case i was able to run both periods, wich shows that there is nothing wrong in the intermediate files produced by ungrib.
I atached my namelist.wps and the metgrid.log.
Does anyone know how to solve this error, or where does it come from?

Thank you very much,
Carolina Bernardo


  • namelist.wps
    1.5 KB · Views: 53
  • metgrid.log
    232.6 MB · Views: 53
I looked through the codes but couldn't find any possible bugs that is relevant to the issue. I am sorry to tell that I don't know the reason why metgrid.exe failed. It is hard for me to repeat this case since it is such a long run.
Please stay with the work-around method at present. I will talk to our expert and see whether we can figure out the issue.