Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error in boundary condition specification

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am trying to run WRF 4.3 using the same namelist options which are workable in WRF 3.9.1 with ERA5 Reanalysis hourly data. I get the error as "Maybe this is a global domain, but the polar flag was not set in the bdy_control namelist." during running the real.exe. After settting polar the error modified to "Error in boundary condition specification".

Any ideas what could be causing this write error?

I had previously run real.exe from 4 older WRF version (of series 4). All of them gives the same error.

I will also attach my namelist.input and rsl.error files.

Any help with this problem would be appreciated!

View attachment boundary_condition__rsl.error.0000.rtf
View attachment namelist.input
View attachment polar__rsl.error.0000.error.rtf
I've seen this issue before and I don't see that it was ever resolved, so I'm interested in digging a little deeper. Can you send your namelist.wps file, along with the initial met_em* file for each domain? Those files will likely be too large to attach here, so take a look at the forum home page for instructions on sending large files. Thanks!
Hi Sumit,
Thanks for sending those files. I was able to test this out with my V4.3 code and I'm not getting that same error. Can you try this again, but this time, make sure to set polar = .false. and also try to set specified = .false. and rerun it to see if that makes any difference? If not,

1) Did you make any modifications to the WRF code, or is it pristine "out-of-the-box" code?
2) Can you send your configure.wrf file so I can compare our set-ups? I'm not sure what else to compare to see why it's happening for you, but not for me.
Thank you for the reply,

Changing the polar specified to false in any combination doesn't change much. Error still remains the same (may be global domain..... and boundary condition specification......).

1) No modification is made in WRF code. The source code is downloaded directly from github, compiled and simulated.
2) The configure.wrf files are attached for different versions below (in which WRF_3.9 is working).
View attachment wrf_all_conf.tar.gz

Also I am using these Module libraries:

Yeah, after I asked you to modify the specification, I later realized that was a poor suggestion. I apologize for that.

Thanks for sending the configuration files. I don't see anything terribly different between our set-ups. This is a bit puzzling to me right now. While I think about this some more, can you try to run just a single domain to see if you get the polar error, and if not, try 2 domains. It may be nice to understand which domain is causing the issue (or if it's all of them). Thanks!
Sorry for the late reply.

As you asked about the domain number change. Initially I started with single domain which doesn't make any difference if it is one or any no. of domain.

However in last few days i made some experiment. Initially we checked the condition in the source code for which the the error is coming in WRF V4 and WRF V3. In WRF V3 it is showing geogrid may be creating error. So I used WPS V3 met files in WRF 4.1, which is directly acceptable without any modification in the Namelist.input with using geogrid and ungrib form V4. However the vice-versa experiment shown the same error. which conclude that the metgrid (of WPS V4) is making some unacceptable met_em files for WRF V4 (not geogrid or ungrib).
I am currently try to see if this issue can be resolved by any mean.
If you required any file or any other details please let me know.

I haven't made much progress in solving this, but I did find a difference in our real.exe output. Notice that it says your max map factor is 0 (which is one of the criteria for giving this error).
Max map factor in domain 1 =  0.00. Scale the dt in the model accordingly.
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:     623
Maybe this is a global domain, but the polar flag was not set in the bdy_control namelist.
while my real output says the max map factor is 1.01, which is correct, according to your met_em.d01* files.
Max map factor in domain 1 =  1.01. Scale the dt in the model accordingly.
So it's odd that real is picking up a different value than is in the met files you shared with me.

Just to be absolutely certain there isn't some sort of issue with the WRF version you have, will you re-download the WRFV4.3 code, compile it again (in a different, clean directory), and then run real.exe, using the exact namelist.input and met_em* files you shared with me? I assume you'll get the same error, but I just want to make sure. Thanks!
Thankyou for the reply.
From starting of compiling of WRF version 4, this experiment was done 6 to 7 times (compiling, deleting, re-downloading and recompiling). Also different HPC ID also used to check if any login ID have any specific issue. We find none. Every time same error generates irrespective of login ID and compilation, in all WRF of version 4 and above (whichever I compiled).

I have another question :
When i use (geogrid.exe and ungrib.exe by WPS-4) WPS3.9 metgrid.exe output files the WRF-4 is not showing any error for real.exe run (it is showing "acceptable met_em* from WPS 3.9"). Is it OK to use WPS-3.9 metgrid.exe out files (met_em*) in WRF-4 run?