Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error in getting timeseries data from LES

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am running a fine resolution LES case and writing time-series files. It worked well when I ran the case with 29 locations. Now as I need more data, I am re-running the same simulation from start (not using restart) and doubled the number of locations to write the TS files. After some time I see the following error in rsl.error.0000 file and the simulation stops:

Timing for main: time 0001-01-01_00:48:09 on domain   1:    3.48464 elapsed seconds
Timing for main: time 0001-01-01_00:48:09 on domain   1:    3.48156 elapsed seconds
Timing for main: time 0001-01-01_00:48:09 on domain   1:    3.48578 elapsed seconds
At line 637 of file wrf_timeseries.f90 (unit = 30)
Fortran runtime error: Cannot send after transport endpoint shutdown

I tried to look at the said Line 637 in wrf_timeseries file and couldn't understand where the problem is coming from. I have enough disk space where the simulation is running.

Any idea on why the TS broke? Is this something to do with the number of processors I am using (=40)?

Thank you
Have you set the namelist options below? if not, please set them based on your case and try again.


Yes, I have set those options so that I get data for all heights and locations. The only option I am unsure of is the buffer size. Currently I have ts_buf_size = 10. Does it have to change with the number of timeseries locations ? If so, is there a thumb rule or best practice to estimate the buffer size required ?

The same settings worked fine when the options max_ts_locs = 30, the only change I made was : max_ts_locs = 60, in the namelist.

Thank you