Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error in running "./real.exe" command in WRF-4.5.1


New member
Hello , I was encountering an error in running the "./real.exe" command in my terminal and the error is

starting wrf task 0 of 1
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 1.
NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.

When i try to look at the rsl.error and rsl.out files, they both show or state the same error regarding the namelists which was I have no idea what to do since I am new to WRF and been only following an online guide from "ARW Online Tutorial" in running WRF. When I turned off and on my laptop (or more like restart), i run the "./real.exe" command again but this time the error was different which says

starting wrf task 0 of 1
[jhcwrf-VirtualBox:01597] [[36556,0],0] ORTE_ERROR_LOG: Data unpack had inadequate space in file ../../../orte/util/show_help.c at line 513

I am using WRF-4.5.1 within a Virtual machine using Linux - Ubuntu OS-22.04. Can someone help me out? I already attached the files regarding the first error below for reference, for the second error I have no idea what to do with it. It would be highly appreciated to hear back with regards to this matter.
Thank You in Advance...


  • rsl.out.0000
    396 bytes · Views: 0
  • rsl.error.0000
    433 bytes · Views: 1
  • namelist.input
    2.9 KB · Views: 1
  • namelist.wps
    634 bytes · Views: 0
The error messages states:

  ------ ERROR while reading namelist domains ------
Maybe here?:      p_top_requested                     = 5000,
Maybe here?:      nnum_metgrid_levels = 32
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:   11575
ERRORS while reading one or more namelists from namelist.input.

This indicates something is incorrect in your namelist.input file (typically a misspelled word, missing comma, a namelist parameter that doesn't belong in that section, or adding additional columns when the model only expects a single entry for that field). Above, it shows where the error may be. The issue is that you have

nnum_metgrid_levels = 32

and it is misspelled. There should only be a single 'n' at the beginning.
Hi, @kwerner your suggestion is what I did first after I reviewed the rsl files.

However, this issue is actually already resolved, and I'll just share what I did to resolve all the errors.

The MPI and ORTE error was resolved by directly copying all of the files into the directory you are currently working on. The problem is that the command provided in the manual didn't link the files into the em_real directory. This only happen to my case but for other laptops, I used the linking successfully through the command in the manual.

In this case, mine is the em_real directory which contains the real.exe file. After that, I was able to run the real.exe and wrf.exe creating the files I needed in making a graphical representation of the data.

Again, thank you.