Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error in running .wrf.exe with mpirun in intel mpi environment

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am trying to locate the error in my wrf.exe run and I will be very grateful if you could point me in the right direction and suggest what may be the issue and I can solve then.

I am basically facing error in running wrf exe with more than one process. i.e. when the mpirun -np 2 .wrf.exe I get 'forrtl: error (78): process killed (SIGTERM)' error while the mpirun -np 1 .wrf.exe runs fine.
I am trying to find what could be wrong? Is it an IT admin issue?
Is it some issue with the modules loaded in the HPC or their versions? Is it the issue with my build?

Just for some more info-
I have compiled the model with intel -18 compiler(dmpar option 15) and intel-mpi. I did not load or use openmpi while compiling ? I tried to recompile the model with openmpi but it gave me the same error.

I am very confused as to where the error is coming from and where I can look to pin point the error. (does it have to do with my compilation or does it have to do with intel compiler or mpi itself? I tried ./clean -a and recompiling many times with intel mpi and openmpi individually. That didn't solve the issue either

Please please help.

I see that srun works-

srun -n 25 ./wrf.exe

I wish to ask since, sru is not very commonly seen to run wrf.
Is it okay to use srun to run wrf and wrf-chem??

PLease suggest

Hi Lin,
I believe the different commands (e.g., mpirun vs. srun) is system-specific, and related to the scheduler. If srun is the command you need to use for your system, then that is perfectly fine to run WRF/WRF-Chem with that command.