Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error in wrf.exe when simulate wind farms

liunj

New member
Hi,

I'm new on WRF and try to simulate wind farm with WRF v4.0. It works well and create wrfout file before I insert 'windfarm_opt = 1,' into namelist.input. However, when I try to simulate wind farm, there is an error:

At line 395 of file module_wind_fitch.f90 (unit = 70, file = 'windturbines.txt')
Fortran runtime error: Bad real number in item 1 of list input

Error termination. Backtrace:
#0 0x7fc308833d5a
#1 0x7fc308834869
#2 0x7fc30883554f
#3 0x7fc308a70cf3
#4 0x7fc308a7215c
#5 0x7fc308a72dc9
#6 0x55b383d94428
#7 0x55b383ce75a9
#8 0x55b3835d8887
#9 0x55b383451e30
#10 0x55b3830a9aec
#11 0x55b382263d62
#12 0x55b382262c34
#13 0x7fc3084af082
#14 0x55b382262c7d
#15 0xffffffffffffffff

The windturbines.txt, namelist.input, and module_wind_fitch.f90 (the extension is modified into .txt due to forum restrict) are attached.
 

Attachments

  • namelist.input
    3.4 KB · Views: 15
  • windturbines.txt
    289 bytes · Views: 19
  • module_wind_fitch.f90.txt
    13 KB · Views: 11
Hi, Can you package all of your error files (e.g., rsl.error.*) together in a single *.tar file and attach that so we can take a look? Thanks!
 
Hi, thanks for your reply. I tried it on the latest WRF v4.4.1 and got the same error. The error file is attached.
 

Attachments

  • rsl.error.tar
    1.5 KB · Views: 4
Thanks for sending that. I figured out the issue, which is with your windturbines.txt file. Depending on how the .txt file was created, sometimes there are hidden value in them. I created my own file to copy yours and then compared the two. See below - yours is the first one and you can see those extra characters that are in there. Screen Shot 2022-11-22 at 11.07.01 AM.png

The way to remove those is to issue
Diff:
dos2unix windturbines.txt

That should fix the issue; however, you are still likely going to run into another issue after, due to the time_step setting you have. This value should never be larger than 6xDX (in km), so you need to decrease time_step to at least 60. If you still aren't able to complete the run, you may want to consider running it with a few more processors. I ran it with 36 processors, but you probably don't need that many. It may be okay with a single processor, though, so no need to change that unless you're still seeing issues.
 
Thanks so much for solving the problem! The WRF is now running well with windturbines.txt. On my workstation, the WRF v4.0 works with time_step of 150, it gives error on v4.4.1 and could run after altering the value to 50.
 
Top