Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error running "real.exe" caused by map scale factor

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I am getting error while running "real.exe (WRF V4.2)". In "rsl.out.00" error occured after the line "Max map factor in domain 1 = 0.00. Scale the dt in the model accordingly". I ran "WPS V4.2" to generate the *met_em* files which is having a correct range of MAPFAC values(range 0.99 to 1.01). Then why it shows "max map factor = 0" ? I am using NCEP FNL data for initialisation.

relevant files attached...


  • namelist.input
    4.2 KB · Views: 68
  • namelist.wps
    2.1 KB · Views: 64
  • rsl.out.0000.txt
    2.8 KB · Views: 69
I repeated your case for D01. The map factor looks reasonable (ranges between 0.98-1.02).
Can you look at MAPFAC_M in your wrfinput files, and let me know the range of their values? They should be around 1.
Thanks for your prompt response.. Actually I got this error while running "real.exe" so I don't have any wrfinput files yet...
As I told the *met_em* files are having a correct range of MAPFAC values(range 0.99 to 1.01).. I don't know what mistake I am doing. Actually I am running a case of 08-aug-2019 and using NCEP-FNL data for initialization. I ran the WRF V3.9 for 2018 some cases and it ran fine but for this new data I am having this error.. any suggestion?
If the same code works, then it is possibly because the data itself is damaged. Can you examine the input data as well as the met-em data that doesn't work for REAL?
hi all
I'm using WRF 4.2.1 and WPS 4.2, and running 4 different parameterizations (in operation, with GFS), wit the same WPS run, meaning that they are all using the same met_em files.
ONLY ONE parameterization started to fail last 03/08, showing the same behavior.
 Domain  1: Current date being processed: 2020-08-31_12:00:00.0000, which is loop #   1 out of   20
 configflags%julyr, %julday, %gmt:        2020         244   12.00000    
d01 2020-08-31_12:00:00  Yes, this special data is acceptable to use: OUTPUT FROM METGRID V4.2
d01 2020-08-31_12:00:00  Input data is acceptable to use:
 metgrid input_wrf.F first_date_input = 2020-08-31_12:00:00
 metgrid input_wrf.F first_date_nml = 2020-08-31_12:00:00
d01 2020-08-31_12:00:00 Timing for input          2 s.
d01 2020-08-31_12:00:00          flag_soil_layers read from met_em file is  1
d01 2020-08-31_12:00:00 Turning off use of MAX WIND level data in vertical interpolation
d01 2020-08-31_12:00:00 Turning off use of TROPOPAUSE level data in vertical interpolation
Max map factor in domain 1 =  0.00. Scale the dt in the model accordingly.
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:     609
Maybe this is a global domain, but the polar flag was not set in the bdy_control namelist.
any thoughts?

thank you in advance