Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ERROR: The mandatory field TT was not found in any input data (RESOLVED)

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I am new to WRF and WRF-Chem. I am trying to run the exercise1 from WRF-Chem tutorials in this link:

As I think, the files in this exercise don't need to use ungrib and only using "./link_grib.csh..." is sufficient.

I did ./geogrid.exe successfully and after that, based on the tutorial, I have typed: ./metgird.exe and this is the error:

Processing domain 1 of 1
Processing 2010-07-14_00
WARNING: Couldn't open file FILE:2010-07-14_00 for input.
ERROR: The mandatory field TT was not found in any input data.

It is my namelist:
View attachment namelist.wps

Please let me know if you have any idea about the error,
Thanks in advance
I have solved my problem and I am posting it for everyone who may have the same problem,

My metgrid.exe was looking for files with the name "FILE:2010-07-14_00 " and the data files that I have been downloaded form the exercise 1 in wrf/chem tutorial exercises have the name "FILE_2010-07-14_00"!!!!

I have renamed the files and the problem has been solved! :D
  • Love
Reactions: jjj
I'm so glad you solved the issue. Thank you for posting an update. It could be very helpful to others!