Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error while simulating past march 2020 FNL data into WRF


New member
Hi Guys,
I am trying to simulate past FNL grib data into WRF-Solar. I successfully simulated data after may 2020 but I am getting error in data before may 2020.
Problem involves in metrid.exe.
I also noticed that FNL file size of march 2020 is also smaller as compared to may 2020. I think I have to edit METGRID.TBL file because looks like some varibles are missing into FNL Data. Please help me getting the solution
Apologies for the delay in response to your inquiry. I just ran a WPS test using GFS FNL data from April 2020 and then again from May 2020. I am not experiencing any differences. Excuse my ignorance, but I am not very familiar with WRF-Solar, as it is managed/developed by a different group at NCAR. Is the WPS process for WRF-Solar any different than for basic WRF? Can you also let me know where you are getting your FNL data? And please also provide your namelist.wps file, as well as your metgrid.log file that shows the error you're getting. Thanks!
Hi @kwerner,
Thanks for looking into it. Sorry I shared wrong date. I successfully simulated FNL data from 1 april,2021 onwards. But I am getting error in, before 1 april 2021 FNL data.
WPS process from WRF-Solar is not any different from basic WRF.
I succesfully ran ungrib.exe. But I am getting error in metgrid.exe. i.e. met_em file can not be produced. I get following error
ERROR: Error in ext_pkg_write_field
application called MPI_Abort(MPI_COMM_WORLD, 0) - process 0

I downloaded FNL data from NCAR RDA Dataset ds083.2.
I am uploading here my ungrib.log,metgrid.log, namelist.wps and METGRID.TBL.
Please help me getting the solution.


  • metgrid.log
    24.4 KB · Views: 1
  • namelist.wps
    1.5 KB · Views: 3
  • ungrib.log
    101.8 KB · Views: 1
Thanks for updating the information. I noticed the paths in your namelist.wps point to older WRF (V3), so I tried this with a V3.8 version of WPS and I was able to get the same error as you. I'm not sure what the exact coding is that causes this, but I believe it's likely related to a change with GFS data that happened right around that time period (see this message). Can you try to process these files using a WPSV4.0+ version and see if that makes a difference?