Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

"Exited with code 174" when running wrf.exe

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Xmen1102

New member
The "wrf.exe" I was running recently was forced to stop halfway through, and the output file shows "exited with code 174". Other errors have not been reported.But the other examples that I ran before are running successfully. I tried to set "ulimit-s unlimited" and changed "time_step" in "namelist.input" file to 120, but it didn't work. When I set "debug_level=1000", the "rsl.error.0000" file appears to be running to "calling Inc/halo_em_couple_b_inline.inc" when it is terminated.How do I solve this problem?
 

Attachments

  • namelist.input
    6.3 KB · Views: 79
  • rsl.error.0000.txt
    214.1 MB · Views: 74
Please reduce time_step to 120 and set w_damping =1. If the domain covers complex terrain area, it is also helpful to set larger values of epssm (for example, epssm= 0.5, 0.5, 0.5).
debug_level can be set to 0 because it doesn't really output helpful information.

Please try the above options and let me know whether this case can run successfully.
 
Thank you for your help.

I tried the above options, but it didn't seem to work, and the same problem still arose-"exited with code 174" :(

I found that the error was reported in "rsl.error.0110", which was "many points exceeded cfl=2 in domain D01", and then led to "Forrtl:severe (174): SIGSEGV, segmentation fault occurred ".
 

Attachments

  • namelist.input
    6.3 KB · Views: 53
  • rsl.error.0000.txt
    1.4 MB · Views: 59
  • rsl.error.0110.txt
    25.8 KB · Views: 65
Your nameless.input looks fine.
CFL violation indicates the model integration became unstable. However, for a 30-km domain, time_step =120 is pretty conservative. I am suspicious that either the data or the physics may go wrong in this case. Please rebuild WRF with the debug option (./configure -d), then rerun the failed case. RSL files will show when and where the code failed, which will give you some hints to find possible causes.
 
Top