Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

First eta level should be 1.0 and the last 0.0 in namelist

Sawyer Smith

New member
Hi,

I found another thread in this forum encountering the same error when running real.exe, however, the solution given to the error in that post (i.e. changing e_vert to match num_metgrid_levels) did not fix my issue and the same error keeps getting thrown: First eta level should be 1.0 and the last 0.0 in namelist.

I should add that I am trying to use hi-res terrain with a moving nest and so I re-ran geogrid, and metgrid for the WPS. My namelist.input and namelist.wps are attached below.

Thanks for the help!
 

Attachments

  • namelist.input.txt
    4.3 KB · Views: 2
  • namelist.wps.txt
    1.2 KB · Views: 0
is there any special reason you want to have 100 vertical levels?
What is the top level of your forcing data?

Can you remove the options below and see whether REAL can run successfully?
max_dz = 1000.,

auto_levels_opt = 2,

dzbot = 40.,

dzstretch_s = 1.07,

dzstretch_u = 1.015,
 
Hi,
There is not a specific reason for the 100 vertical levels. This is an inherited namelist and so I just left that as is. The top level of my forcing data is 50 hPa. I removed the 5 aforementioned variables above but REAL still did not run successfully and resulted in the same initial error getting thrown. I also tried to changed e_vert to 38 and p_top_requested to 5000, however, that also did not fix the issue.

Also, when I try to run real.exe, it will not read my met_em* files because the naming convention of the file is met_em.d01.2012-12-19_00_00_00.nc, but when I change it to met_em.d01.2012-12-19_00:00:00.nc, it reads it. I have not had this issue in the past. Do you know why this occurs and is there a way to change this setting or should I just rename all of my met_em* files to *:00:00.nc?

Thanks!
 
One important issue is that, the model top should not be higher than the top of the forcing data. In your case, if the top level of your forcing data is 50 hPa, then p_top_requested must be below 50 hpa.
 
Top