Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

forrtl: error (78): process killed (SIGTERM)


New member
After generating the boundary and input files from real I am now trying to run WRF, but it stops after the first time step. In the rsl.error file I see there are some warnings of the type:
W A R N I N G : Unable to modify mask for soiltemp. Variable not found. File: rcm_iofields_d01.txt at line 1
W A R N I N G : Unable to modify mask for sai. Variable not found. File: rcm_iofields_d01.txt at line 1
I don't know how critical these are to running WRF, but I can't see any other reasons for WRF to stop running.
I've attached the rsl.out, rsl.error and namelist files - maybe someone has some idea of the problem?

Thanks very much!


  • rsl.error.0000
    10.5 KB · Views: 1
  • rsl.out.0000
    9 KB · Views: 0
  • namelist.input
    7.9 KB · Views: 2
Please delete the line below:

iofields_filename = "rcm_iofields_d01.txt", "rcm_iofields_d02.txt", "rcm_iofields_d03.txt"

Then rerun the case.

if the case works, it tells that something is wrong in rcm_iofields files. We can then look at these files.
I deleted this line from the namelist file, re-ran WRF but the same error is produced. I set the debug level in the namelist file to 1 to print out more information. It looks like it stops after the second minute is processed, but it is not clear what the reason for the error is.


  • namelist.input
    7.9 KB · Views: 2
  • rsl.error.0000
    135.3 KB · Views: 2
Your namelist still contains the line:
iofields_filename = "rcm_iofields_d01.txt", "rcm_iofields_d02.txt", "rcm_iofields_d03.txt"

Please confirm that you deleted this line in your run.
Hi, yes I deleted this line, ran WRF again and I got the same error, without the first time step being processed.
When I put this line back in and set debug level to 1 to get more information on the error, I saw that the first 2 minutes had been processed, then the same error was produced again.
if the model crashed immediately after wrf.exe started, it often indicates the input data is wrong. Can you tell what data you used to produce initiial and boundary conditions for this case?
Last edited:
I used a python package (pywinter) to produce WRF intermediate files for MPI-ESM1.2 HR data, I then ran metgrid on these to make the met_em files, and finally ran real on these met_em files to produce the WRF input and boundary files. In the rsl.error.0000 file it says that these input files are acceptable to use, so I am not sure what error in the data I am looking for if I view the boundary/input files in ncview.